summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-25 08:58:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-25 09:45:21 +0200
commit550e51152d9181eada7a1f83d1a74f5789e2fe9f (patch)
treea0423a725caffc920b8c45347dd3cbda1f048f28 /dev-util/debugedit
parentdev-python/regex: Bump to 2021.9.24 (diff)
downloadgentoo-550e51152d9181eada7a1f83d1a74f5789e2fe9f.tar.gz
gentoo-550e51152d9181eada7a1f83d1a74f5789e2fe9f.tar.bz2
gentoo-550e51152d9181eada7a1f83d1a74f5789e2fe9f.zip
dev-util/debugedit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/Manifest1
-rw-r--r--dev-util/debugedit/debugedit-4.16.1.3.ebuild91
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index 442b79c16b5b..0cc85f3d9375 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -1,3 +1,2 @@
DIST debugedit-5.0.tar.xz 164820 BLAKE2B 8e79f930a7e5c91709b1646794412836fff0b08da17a4b54beac4752a3f62c7418e3e8b8f7f3c3111ba375d6c672fee0f4279632bab3fb406a2fdd75a9e81a64 SHA512 7e7f529eafe41b53f0b5bfc58282fdbfa0dfa93ed7908b70e81942d6d2b6f80fc9c6bff2ed9674fd98947e5750b615f4c8b222544989e2900c5f8ff5ae0efb92
DIST debugedit-5.0.tar.xz.sig 310 BLAKE2B bd8b092e400575fa62f759e4fd2e6bbfc9dbd77da2a363bd13c98b32794d515fbe7987824874b9c4be048e458c334bccb74082a78d845f07429b150083f2bcbf SHA512 2223841eb6c63616dc24028e8076ab9d82579e8d6efa4bba45e5dbd0eb181c947feae6f944136f3504a78678569ae96dc6c4a0dd4e7012bd9aa522b0f7525dc9
-DIST rpm-4.16.1.3.tar.bz2 4354652 BLAKE2B 10013014bdeaf908b64c90f8e76f1d4b0cd0e8cb926f0cd979d7b1e1963b9a25c5b98531deea7e74e00168e2e6349f443fa4578c69c717ca1ab5e6b79d801f3a SHA512 54e503b32dffaa73d6168f26a00220d9d9124082d8a1eb1ddf34ce32a482f07cb06ec654cf065fca1607cc37b13fa7d4fa9895553541d7cfddecf68c9eb96f2e
diff --git a/dev-util/debugedit/debugedit-4.16.1.3.ebuild b/dev-util/debugedit/debugedit-4.16.1.3.ebuild
deleted file mode 100644
index 17d121e9642e..000000000000
--- a/dev-util/debugedit/debugedit-4.16.1.3.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-MY_P=rpm-${PV}
-DESCRIPTION="Stand-alone debugedit from RPM"
-HOMEPAGE="https://rpm.org
- https://github.com/rpm-software-management/rpm"
-SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- sys-libs/zlib:=
- >=dev-libs/popt-1.7
- >=dev-libs/elfutils-0.176-r1
- dev-libs/nss
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- eapply_user
-
- # cheat it into believing we're bundling db
- mkdir -p db/dist || die
- touch db/dist/configure || die
- chmod +x db/dist/configure || die
- echo 'install:' > db3/Makefile || die
-
- # TODO: why do we need to do this?
- mkdir rpm || die
- find -name '*.h' -exec cp {} rpm/ ';' || die
-}
-
-src_configure() {
- append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
- local myconf=(
- # force linking to static librpmio
- --disable-shared
-
- # disable linking compression libraries
- ac_cv_header_bzlib_h=no
- ac_cv_header_lzma_h=no
- --disable-zstd
-
- # fake some libraries we don't use
- ac_cv_header_magic_h=yes
- ac_cv_lib_magic_magic_open=yes
-
- # use nss as crypto provider
- --with-crypto=nss
-
- # disable other stuff irrelevant to debugedit
- --disable-bdb
- --disable-nls
- --disable-plugins
- --disable-python
- --without-acl
- --without-archive
- --without-cap
- --without-external-db
- --without-hackingdocs
- --without-lua
- --without-selinux
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake -C misc
- emake -C rpmio
- emake debugedit
-}
-
-src_test() {
- :
-}
-
-src_install() {
- dobin debugedit
-}