summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dirdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dirdiff')
-rw-r--r--dev-util/dirdiff/Manifest1
-rw-r--r--dev-util/dirdiff/dirdiff-2.1-r2.ebuild40
-rw-r--r--dev-util/dirdiff/files/dirdiff-2.1-build.patch28
-rw-r--r--dev-util/dirdiff/files/dirdiff-2.1-funky-chars.patch201
-rw-r--r--dev-util/dirdiff/files/dirdiff-2.1-include.patch10
-rw-r--r--dev-util/dirdiff/files/dirdiff-2.1-tcl8.6.patch16
-rw-r--r--dev-util/dirdiff/files/dirdiff-2.1-vcs.patch16
-rw-r--r--dev-util/dirdiff/metadata.xml7
8 files changed, 319 insertions, 0 deletions
diff --git a/dev-util/dirdiff/Manifest b/dev-util/dirdiff/Manifest
new file mode 100644
index 000000000000..cb01607a6df7
--- /dev/null
+++ b/dev-util/dirdiff/Manifest
@@ -0,0 +1 @@
+DIST dirdiff-2.1.tar.gz 43105 SHA256 cb373654d5788027804355e355df0695862c3bfc1f6a3fc6014722b3156a9252 SHA512 826d5a7a633921bec7043c89ccdadff19b4a6328efd09913932b306a48242203fbf6b5bac69d72660acf2c76ce6c8c5e53be62c2e69bbf3e3717e21c544ca261 WHIRLPOOL db5342743f3c6719de6645e11f6eda883d27fc9fa83380022e4a11c5e897fd4a0066aa696316d9f262951a6500c8cfcd48afb3d59d2e9080823eda93f174cda5
diff --git a/dev-util/dirdiff/dirdiff-2.1-r2.ebuild b/dev-util/dirdiff/dirdiff-2.1-r2.ebuild
new file mode 100644
index 000000000000..00f9db57c924
--- /dev/null
+++ b/dev-util/dirdiff/dirdiff-2.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="A tool for differing and merging directories"
+SRC_URI="http://samba.org/ftp/paulus/${P}.tar.gz"
+HOMEPAGE="http://samba.org/ftp/paulus/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+
+DEPEND="
+ dev-lang/tk:0=
+ dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-include.patch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-vcs.patch \
+ "${FILESDIR}"/${P}-tcl8.6.patch \
+ "${FILESDIR}"/${P}-funky-chars.patch
+ tc-export CC
+ append-cppflags -I"${EPREFIX}"/usr/include/tcl
+}
+
+src_install() {
+ dobin dirdiff
+ dolib.so libfilecmp.so.0.0
+ dosym libfilecmp.so.0.0 /usr/$(get_libdir)/libfilecmp.so.0
+ dosym libfilecmp.so.0.0 /usr/$(get_libdir)/libfilecmp.so
+ dodoc README
+}
diff --git a/dev-util/dirdiff/files/dirdiff-2.1-build.patch b/dev-util/dirdiff/files/dirdiff-2.1-build.patch
new file mode 100644
index 000000000000..bb5010265196
--- /dev/null
+++ b/dev-util/dirdiff/files/dirdiff-2.1-build.patch
@@ -0,0 +1,28 @@
+ Makefile | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b4a49f8..410e018 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,12 +7,17 @@ LIBDIR=$(DESTDIR)/usr/lib
+ INSTALL=install
+
+ # You may need to change the -I arguments depending on your system
+-CFLAGS=-O3 -I/usr/include/tcl8.3/ -I/usr/include/tcl
++#CFLAGS=-O3 -I/usr/include/tcl8.3/ -I/usr/include/tcl
++
++LIBS = -ltcl
+
+ all: libfilecmp.so.0.0
+
+-libfilecmp.so.0.0: filecmp.c
+- $(CC) $(CFLAGS) -shared -o $@ filecmp.c
++.c.o:
++ $(CC) $(CPPFLAGS) $(CFLAGS) -fPIC -c $< -o $@
++
++libfilecmp.so.0.0: filecmp.o
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,libfilecmp.so.0 -o $@ filecmp.o $(LIBS)
+
+ install: dirdiff libfilecmp.so.0.0
+ $(INSTALL) -c dirdiff $(BINDIR)
diff --git a/dev-util/dirdiff/files/dirdiff-2.1-funky-chars.patch b/dev-util/dirdiff/files/dirdiff-2.1-funky-chars.patch
new file mode 100644
index 000000000000..1d4f715ac167
--- /dev/null
+++ b/dev-util/dirdiff/files/dirdiff-2.1-funky-chars.patch
@@ -0,0 +1,201 @@
+--- cvs-local.orig/dirdiff
++++ cvs-local/dirdiff
+@@ -563,7 +563,7 @@
+ if {$d1 == $d2} continue
+ set any 1
+ $base.p.$sub1 add command -label "$d2" \
+- -command "makepatch \"$d1\" \"$d2\""
++ -command [list makepatch $d1 $d2]
+ }
+ if {$any} {
+ $base.p add cascade -label "$d1 ->" -menu $base.p.$sub1
+@@ -579,7 +579,7 @@
+ set i 0
+ foreach d $dirs {
+ if {!$dirreadonly($i)} {
+- $base.t add command -label $d -command "touchfiles \"$d\""
++ $base.t add command -label $d -command [list touchfiles $d]
+ }
+ incr i
+ }
+@@ -677,7 +677,7 @@
+ set i 0
+ foreach d $dirs {
+ .bar.options add checkbutton -label "Read-only $d" \
+- -variable dirreadonly($i) -command "readonlychange $i"
++ -variable dirreadonly($i) -command [list readonlychange $i]
+ incr i
+ }
+
+@@ -1153,7 +1153,7 @@
+ if {$xi != ""} {
+ set x [lindex $dirs $xi]
+ $diffbut add command -label "Show $x" \
+- -command "showfile \"$x\" \"$selfile\""
++ -command [list showfile $x $selfile]
+ }
+ } elseif {$numgroups > 1} {
+ if {$numgroups > 2} {
+@@ -1163,7 +1163,7 @@
+ lappend x [lindex $dirs $i]
+ }
+ $diffbut add command -label "$numgroups-way diff" \
+- -command "diffn {$x} {$selfile}"
++ -command [list diffn $x $selfile]
+ }
+ for {set gn 1} {$gn < $numgroups} {incr gn} {
+ set yi [lindex $groupelts($gn) 0]
+@@ -1184,7 +1184,7 @@
+ set xi [lindex $groupelts($go) 0]
+ if {$xi == ""} continue
+ set x [lindex $dirs $xi]
+- set cmd "diff2 \"$x\" \"$y\" \"$selfile\""
++ set cmd [list diff2 $x $y $selfile]
+ if {$numgroups <= 3} {
+ if {$compound_ok} {
+ $diffbut add command -label "$x vs. $y" \
+@@ -1283,7 +1283,7 @@
+ set cl2 [lindex $bgcolors($ng) $age]
+ if {$im2 == "ex"} {set im2 ""}
+ set y [lindex $dirs $dst]
+- set cmd "copyselfile \"$src\" \"$dst\" \"$selfile\" 0"
++ set cmd [list copyselfile $src $dst $selfile 0]
+ if {$any == 1} {
+ if {$compound_ok} {
+ $copybut add command -label "$x -> $y" \
+@@ -1346,7 +1346,7 @@
+ set im2 [lindex $agecolors($ng) $age]
+ set cl2 [lindex $bgcolors($ng) $age]
+ set y [lindex $dirs $dst]
+- set cmd "copyselfile \"$src\" \"$dst\" \"$selfile\" 1"
++ set cmd [list copyselfile $src $dst $selfile 1]
+ if {$any == 1} {
+ if {$compound_ok} {
+ $copybut add command -label "$x -> $y" \
+@@ -1392,10 +1392,10 @@
+ if {$compound_ok} {
+ $copybut add command -label "Remove from $x" \
+ -image ex -compound left \
+- -command "removeselfile \"$dst\" \"$selfile\""
++ -command [list removeselfile $dst $selfile]
+ } else {
+ $copybut add command -label "Remove from $x" \
+- -command "removeselfile \"$dst\" \"$selfile\""
++ -command [list removeselfile $dst $selfile]
+ }
+ }
+ }
+@@ -1415,7 +1415,7 @@
+ if {$dirreadonly($d)} continue
+ set y [lindex $dirs $d]
+ $copybut add command -label "$x -> $y" \
+- -command "copyselfile \"$s\" \"$d\" \"$selfile\" 0"
++ -command [list copyselfile $s $d $selfile 0]
+ }
+ }
+ set needsep 1
+@@ -1429,10 +1429,10 @@
+ if {$compound_ok} {
+ $copybut add command -label "Remove from $x" \
+ -image ex -compound left \
+- -command "removeselfile \"$s\" \"$selfile\""
++ -command [list removeselfile $s $selfile]
+ } else {
+ $copybut add command -label "Remove from $x" \
+- -command "removeselfile \"$s\" \"$selfile\""
++ -command [list removeselfile $s $selfile]
+ }
+ }
+ }
+@@ -1469,7 +1469,7 @@
+
+ # Show the file in an external viewer
+ if { [llength $showprogram] > 0} {
+- eval "exec $showprogram \"$fn\" &"
++ exec $showprogram $fn &
+ return
+ }
+ # Or make our own viewer
+@@ -1569,7 +1569,7 @@
+ set diffopts "-U $ctxlines $diffiflag $diffwflag $diffbflag $diffBflag $diffdflag"
+
+ if { [llength $diffprogram] > 0} {
+- eval "exec $diffprogram \"$path1\" \"$path2\" &"
++ exec $diffprogram $path1 $path2 &
+ return
+ }
+ # If we used an external diff program, its options are used. If we didn't,
+@@ -1750,7 +1750,7 @@
+ if {$gx == $g && !$dirreadonly($k)} {
+ set f [lindex $dirs $k]
+ $mergebut.m add command -label "update $f" \
+- -command "diffmerge $i \"$f\""
++ -command [list diffmerge $i $f]
+ set path [joinname $f $difffile]
+ set diffmtime($path) [file mtime $path]
+ }
+@@ -1770,7 +1770,7 @@
+ if {$gx == $g && !$dirreadonly($k)} {
+ set f [lindex $dirs $k]
+ $mpatchbut.m add command -label "for $f" \
+- -command "diffmpatch $i \"$f\""
++ -command [list diffmpatch $i $f]
+ }
+ incr k
+ }
+@@ -3424,7 +3424,7 @@
+ $w.bar.edit.m add command -label Copy -command "tk_textCopy $w.t"
+ $w.bar.edit.m add command -label Paste -command "tk_textPaste $w.t"
+ $w.bar.edit.m add command -label Find \
+- -command "difffind :merge:$di:$fi $w.t"
++ -command [list difffind :merge:$di:$fi $w.t]
+ pack $w.bar.edit -side left
+ frame $w.f -relief sunk -border 2
+ entry $w.f.filename
+@@ -3533,7 +3533,7 @@
+ $w.bar.edit.m add command -label Copy -command "tk_textCopy $w.t"
+ $w.bar.edit.m add command -label Paste -command "tk_textPaste $w.t"
+ $w.bar.edit.m add command -label Find \
+- -command "difffind :mpatch:$fi $w.t"
++ -command [list difffind :mpatch:$fi $w.t]
+ pack $w.bar.edit -side left
+ frame $w.f -relief sunk -border 2
+ entry $w.f.filename
+@@ -3993,7 +3993,7 @@
+ $w.bar.edit.m add command -label Copy -command "tk_textCopy $w.t"
+ $w.bar.edit.m add command -label Paste -command "tk_textPaste $w.t"
+ $w.bar.edit.m add command -label Find \
+- -command "difffind :patch:$patchnum $w.t"
++ -command [list difffind :patch:$patchnum $w.t]
+ pack $w.bar.edit -side left
+ frame $w.f -relief sunk -border 2
+ label $w.f.l -text "Filename: "
+@@ -4032,23 +4032,23 @@
+ set p1 [joinname $d1 $f]
+ set p2 [joinname $d2 $f]
+ if {[file exists $p1] && [file exists $p2]} {
+- set fh [open "|diff $contextopt $p1 $p2" r]
++ set fh [open [list |diff $contextopt $p1 $p2] r]
+ } elseif {[file exists $p1] && ! [file exists $p2]} {
+- set fh [open "|diff $contextopt $p1 $nullfile" r]
++ set fh [open [list |diff $contextopt $p1 $nullfile] r]
+ } elseif {! [file exists $p1] && [file exists $p2]} {
+- set fh [open "|diff $contextopt $nullfile $p2" r]
++ set fh [open [list |diff $contextopt $nullfile $p2] r]
+ } else {
+ continue
+ }
+ fconfigure $fh -blocking 0
+- fileevent $fh readable "readpatch $fh $pnum $w $d1 $d2 $i \"$f\""
++ fileevent $fh readable [list readpatch $fh $pnum $w $d1 $d2 $i $f]
+ return
+ }
+ if {[string match ".*" $w]} {
+ $w.t delete "end - 1c" end
+ } else {
+ close $w
+- eval "exec $showprogram \"$patch_outfile\" &"
++ exec $showprogram $patch_outfile &
+ # Should we remove the tempfile here? We don't have it if we used
+ # the internal viewer
+ }
diff --git a/dev-util/dirdiff/files/dirdiff-2.1-include.patch b/dev-util/dirdiff/files/dirdiff-2.1-include.patch
new file mode 100644
index 000000000000..acaed3cf8026
--- /dev/null
+++ b/dev-util/dirdiff/files/dirdiff-2.1-include.patch
@@ -0,0 +1,10 @@
+--- a/filecmp.c 2005-04-19 12:22:01.000000000 +0200
++++ b/filecmp.c 2010-12-30 20:23:24.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include <ctype.h>
+ #include <tcl.h>
+ #include <sys/fcntl.h>
++#include <unistd.h> /* close() read() */
+
+ #define BSIZE 32768
+ #define MAXTAGLEN 512 /* max tag length for sanity, < BSIZE */
diff --git a/dev-util/dirdiff/files/dirdiff-2.1-tcl8.6.patch b/dev-util/dirdiff/files/dirdiff-2.1-tcl8.6.patch
new file mode 100644
index 000000000000..39d930a51724
--- /dev/null
+++ b/dev-util/dirdiff/files/dirdiff-2.1-tcl8.6.patch
@@ -0,0 +1,16 @@
+ filecmp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/filecmp.c b/filecmp.c
+index 673c1a8..fd4c6e5 100644
+--- a/filecmp.c
++++ b/filecmp.c
+@@ -341,7 +341,7 @@ FileCmpCmd(clientData, interp, argc, argv)
+ if (n1 < 0 || n2 < 0)
+ return TCL_ERROR;
+
+- sprintf(interp->result, "%d", same);
++ sprintf(Tcl_GetStringResult(interp), "%d", same);
+ return TCL_OK;
+ }
+
diff --git a/dev-util/dirdiff/files/dirdiff-2.1-vcs.patch b/dev-util/dirdiff/files/dirdiff-2.1-vcs.patch
new file mode 100644
index 000000000000..b8db24509eaa
--- /dev/null
+++ b/dev-util/dirdiff/files/dirdiff-2.1-vcs.patch
@@ -0,0 +1,16 @@
+ dirdiff | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dirdiff b/dirdiff
+index c5522b6..f470348 100755
+--- a/dirdiff
++++ b/dirdiff
+@@ -37,7 +37,7 @@ set nxdirmode 0
+ set docvsignore 0
+
+ set defaultcvsignore {
+- RCS SCCS CVS CVS.adm RCSLOG cvslog.* tags TAGS
++ RCS SCCS CVS CVS.adm RCSLOG cvslog.* .svn .git tags TAGS
+ .make.state .nse_depinfo *~ \#* .\#* ,* _$* *$
+ *.old *.bak *.BAK *.orig *.rej .del-* *.a *.olb
+ *.o *.obj *.so *.exe *.Z *.elc *.ln core
diff --git a/dev-util/dirdiff/metadata.xml b/dev-util/dirdiff/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/dev-util/dirdiff/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>