summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-05-16 11:51:49 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-05-16 11:54:02 -0500
commit7edb163b3b2ae7c0103975bb7b6a99549d2cbfae (patch)
tree90c51b3c2551a8dc15865aab227029cc25a76768 /dev-util/gitlab-cli
parentsys-fs/exfatprogs: Keyword 1.2.0 arm64, #906552 (diff)
downloadgentoo-7edb163b3b2ae7c0103975bb7b6a99549d2cbfae.tar.gz
gentoo-7edb163b3b2ae7c0103975bb7b6a99549d2cbfae.tar.bz2
gentoo-7edb163b3b2ae7c0103975bb7b6a99549d2cbfae.zip
dev-util/gitlab-cli: add 1.29.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-cli')
-rw-r--r--dev-util/gitlab-cli/Manifest2
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/Manifest b/dev-util/gitlab-cli/Manifest
index 50708a5f45b1..92620699ff39 100644
--- a/dev-util/gitlab-cli/Manifest
+++ b/dev-util/gitlab-cli/Manifest
@@ -8,3 +8,5 @@ DIST gitlab-cli-1.27.1-deps.tar.xz 36052928 BLAKE2B afc415014e36bf5ccc0f454cff85
DIST gitlab-cli-1.27.1.tar.bz2 16780511 BLAKE2B d0baba9a6269deec6b98dd620e47c21eaa821fe3ef608478edb3e599ef13576f00e8f80424fa1ac42f894bf9d8c456f9e75d3d83899ac99754acec8e597c290a SHA512 74413f538b4983cbcdfa4a9197e38d6d52d4c675e708bc459d4460e61af4663394b2776d6568a294f1249fe7de21b882a95a68130100769fceb29ba725458d07
DIST gitlab-cli-1.28.1-deps.tar.xz 36252544 BLAKE2B 8c7d4ef554bec4c7e8216bffd8ff138dfaa4aca5ede0d8e68d9291f296121f77bb0e607629dbeadd854ddc767ece394e8e22100f52776d704bd1908e1f0ac5e6 SHA512 6e6d2283a19ef1160ac933399cc497ea92075d7fc0bbc2bc998614b5c077b0331796a224f472139a4f6f273a2e1271ac70ea5ab7c0a479bb749055980e31e2e9
DIST gitlab-cli-1.28.1.tar.bz2 16781342 BLAKE2B 0b59e60d0f8b7f1e95bbdf1aff8c22017dbf54eae2a72848a5416c35bee893341c1606249eeeaee1ffff1aa72500a8fe91389358abdf066339d9218a6ecdc648 SHA512 57b9d6e2b527bcaf227d8c07101129749a80203db061ac757adc84bda72576e35f6404d80972ffcecb6fecd2e9b644b0e5c9a06b6135a7e3a68c46af82de69b1
+DIST gitlab-cli-1.29.4-deps.tar.xz 38656412 BLAKE2B fcbb787a1fb893ae8d3452919e9e540f011ce0d35827a383f083e1492018a335f80089f2f87315329afb42bebdd1014ef6dc59e6673b930d4397edfa57384513 SHA512 12382eb22cf71cf11ebdfacf834dbcd08d6dc5fb02f7f705772240d896b907e8054a1847976a1ba9105b765df194eb5581dbd8d77fc191ac01b63257f1e76370
+DIST gitlab-cli-1.29.4.tar.bz2 16787326 BLAKE2B d0cc93c92cfb9ae01b9acfec04341c1e06a1bce36f666abec46c6bd0eab6700e2b6ea4f8cc27606da499b8246795c145a402dbf32c8f94074c0feaae34b8ec8a SHA512 a212f73fb06849c1d197efac1a7cf33a09fc94a3b8d954de1d442462deb59e52ff1a89c68e6ce4deb0a1472367890947ccabebfd459fd6e172142a9931c68df1
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
new file mode 100644
index 000000000000..10e6e59a82ab
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=654ae7c117d2d93fc4621b58a8cfb5388ba485a0
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}