summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-21 04:15:41 +0000
committerSam James <sam@gentoo.org>2021-12-21 04:19:20 +0000
commitc238e7df2bc5e2f15862ede0096b5aa39c3eef78 (patch)
tree2560b7d5ebbf1c6e56091618c5b744d9c45818ea /dev-util/icemon
parentsys-devel/icecream: update EAPI 7 -> 8, post-review fixes (diff)
downloadgentoo-c238e7df2bc5e2f15862ede0096b5aa39c3eef78.tar.gz
gentoo-c238e7df2bc5e2f15862ede0096b5aa39c3eef78.tar.bz2
gentoo-c238e7df2bc5e2f15862ede0096b5aa39c3eef78.zip
dev-util/icemon: add 3.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/icemon')
-rw-r--r--dev-util/icemon/Manifest1
-rw-r--r--dev-util/icemon/icemon-3.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/icemon/Manifest b/dev-util/icemon/Manifest
index fa0adc4d577e..0d2b4dc236ea 100644
--- a/dev-util/icemon/Manifest
+++ b/dev-util/icemon/Manifest
@@ -1 +1,2 @@
DIST icemon-3.1.0.tar.gz 111139 BLAKE2B b37f17a34237e76cd3f7aaad88de903d1a3ac4aec9478613dbfbaab950eac36af33f49b97330a7c7d0ca06ab9bc56d25960142f7149a198acc2c5d35b32faf09 SHA512 43b5c959cd66fa65cac25994e5b8f26646b49b57405bd80d6ddb12cc7ed5bfeb5f91f5816900883078075685c25159f5a19b3198594027b3a1b8b0c489237b39
+DIST icemon-3.3.tar.xz 95308 BLAKE2B e387bccd4361ddcf852ad07207ff9007cd70c16ab6bfda3d4a4a4a620a826bd4969d95613aeaa51f1977f4fe00068e3deca90b31e3bc963795c6461f4a14e2d1 SHA512 326e28959b9f3c9223dec38507414ca44b99cdb52282da27d1f3f96305d9f7e595eb1b9949021957f1b21d5b95811c8de2d9f33a78bc985616f7001bb20eb81d
diff --git a/dev-util/icemon/icemon-3.3.ebuild b/dev-util/icemon/icemon-3.3.ebuild
new file mode 100644
index 000000000000..e7f88128823d
--- /dev/null
+++ b/dev-util/icemon/icemon-3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Monitor program for use with Icecream compile clusters based on KDE Frameworks"
+HOMEPAGE="https://en.opensuse.org/Icecream https://github.com/icecc/icemon"
+SRC_URI="https://github.com/icecc/icemon/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-devel/icecream-1.3"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook2X
+ kde-frameworks/extra-cmake-modules"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
+ )
+
+ cmake_src_configure
+}