summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-29 12:35:19 +0200
committerSam James <sam@gentoo.org>2022-05-01 20:53:36 +0100
commitd52666486cf6c2fa7ffaa9ee3ad8f3f449275213 (patch)
tree8248ff86b20767226a4fb3022da37d6c5c851691 /dev-util/intel-graphics-compiler
parentmedia-video/pipewire: respect prefix for 99-pipewire-default-hook.conf (diff)
downloadgentoo-d52666486cf6c2fa7ffaa9ee3ad8f3f449275213.tar.gz
gentoo-d52666486cf6c2fa7ffaa9ee3ad8f3f449275213.tar.bz2
gentoo-d52666486cf6c2fa7ffaa9ee3ad8f3f449275213.zip
dev-util/intel-graphics-compiler: force LLVM12 instead LLVM13
Compiling with LLVM13 causes currently segfaults. See https://github.com/intel/intel-graphics-compiler/issues/204 Closes: https://bugs.gentoo.org/837872 Signed-off-by: Conrad Kostecki <conikost@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r2.ebuild (renamed from dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r1.ebuild)7
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988-r1.ebuild (renamed from dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988.ebuild)7
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild86
3 files changed, 4 insertions, 96 deletions
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r1.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r2.ebuild
index 78d2327a49ee..6c079df6172d 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r1.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10778-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CMAKE_BUILD_TYPE="Release"
-LLVM_MAX_SLOT="13"
+LLVM_MAX_SLOT="12"
MY_PN="igc"
MY_P="${MY_PN}-${PV}"
PYTHON_COMPAT=( python3_{8..10} )
@@ -72,15 +72,12 @@ src_configure() {
-DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS="ON"
-DINSTALL_GENX_IR="ON"
-DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
+ -Wno-dev
# Compilation with VectorCompiler causes currently a segfault.
# See https://github.com/intel/intel-graphics-compiler/issues/236
-DIGC_BUILD__VC_ENABLED="OFF"
# -DIGC_OPTION__VC_INTRINSICS_MODE="Prebuilds"
-
- # This will suspress some CMake warnings,
- # which cannot be fixed at the moment.
- -Wno-dev
)
cmake_src_configure
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988-r1.ebuild
index fc02ff9997b0..e6c00047ccc6 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.10988-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CMAKE_BUILD_TYPE="Release"
-LLVM_MAX_SLOT="13"
+LLVM_MAX_SLOT="12"
MY_PN="igc"
MY_P="${MY_PN}-${PV}"
PYTHON_COMPAT=( python3_{8..10} )
@@ -71,15 +71,12 @@ src_configure() {
-DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS="ON"
-DINSTALL_GENX_IR="ON"
-DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
+ -Wno-dev
# Compilation with VectorCompiler causes currently a segfault.
# See https://github.com/intel/intel-graphics-compiler/issues/236
-DIGC_BUILD__VC_ENABLED="OFF"
# -DIGC_OPTION__VC_INTRINSICS_MODE="Prebuilds"
-
- # This will suspress some CMake warnings,
- # which cannot be fixed at the moment.
- -Wno-dev
)
cmake_src_configure
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild
deleted file mode 100644
index fc02ff9997b0..000000000000
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11061.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-LLVM_MAX_SLOT="13"
-MY_PN="igc"
-MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake flag-o-matic llvm python-any-r1
-
-DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
-HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
-SRC_URI="https://github.com/intel/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug"
-
-DEPEND="
- dev-libs/opencl-clang:${LLVM_MAX_SLOT}=
- dev-util/spirv-tools
- =sys-devel/lld-${LLVM_MAX_SLOT}*
- sys-devel/llvm:${LLVM_MAX_SLOT}=
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- =sys-devel/lld-${LLVM_MAX_SLOT}*
- ${PYTHON_DEPS}
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
- "${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
- "${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
-)
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # Get LLVM version
- local llvm_version="$(best_version -d sys-devel/llvm:${LLVM_MAX_SLOT})"
-
- # See https://github.com/intel/intel-graphics-compiler/issues/212
- append-ldflags -Wl,-z,undefs
-
- # See https://bugs.gentoo.org/718824
- ! use debug && append-cppflags -DNDEBUG
-
- local mycmakeargs=(
- -DCCLANG_SONAME_VERSION="${LLVM_MAX_SLOT}"
- -DCMAKE_LIBRARY_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)"
- -DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
- -DIGC_OPTION__CLANG_MODE="Prebuilds"
- -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR="ON"
- -DIGC_OPTION__LLD_MODE="Prebuilds"
- -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
- -DIGC_OPTION__LLVM_MODE="Prebuilds"
- -DIGC_OPTION__LLVM_PREFERRED_VERSION="${llvm_version##*-}"
- -DIGC_OPTION__SPIRV_TOOLS_MODE="Prebuilds"
- -DIGC_OPTION__SPIRV_TRANSLATOR_MODE="Prebuilds"
- -DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS="ON"
- -DINSTALL_GENX_IR="ON"
- -DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
-
- # Compilation with VectorCompiler causes currently a segfault.
- # See https://github.com/intel/intel-graphics-compiler/issues/236
- -DIGC_BUILD__VC_ENABLED="OFF"
- # -DIGC_OPTION__VC_INTRINSICS_MODE="Prebuilds"
-
- # This will suspress some CMake warnings,
- # which cannot be fixed at the moment.
- -Wno-dev
- )
-
- cmake_src_configure
-}