summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-23 12:22:59 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-23 12:24:05 -0500
commit6078d22d82277763e6118cd08556e6d20f07ed55 (patch)
tree3819b4dd14181000b9f9d2325a7b29ec161b3bcc /dev-util/kubeval/kubeval-0.16.1.ebuild
parentapp-emacs/web-mode: new package; add version 17.2.1 (diff)
downloadgentoo-6078d22d82277763e6118cd08556e6d20f07ed55.tar.gz
gentoo-6078d22d82277763e6118cd08556e6d20f07ed55.tar.bz2
gentoo-6078d22d82277763e6118cd08556e6d20f07ed55.zip
dev-util/kubeval: new package, add 0.16.1
kubeval validates kubernetes YAML or JSON configuration files using schemas generated from the kubernetes OpenAPI specification. This means it can validate schemas for multiple versions of kubernetes. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/kubeval/kubeval-0.16.1.ebuild')
-rw-r--r--dev-util/kubeval/kubeval-0.16.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/kubeval/kubeval-0.16.1.ebuild b/dev-util/kubeval/kubeval-0.16.1.ebuild
new file mode 100644
index 000000000000..4eac1a6a402c
--- /dev/null
+++ b/dev-util/kubeval/kubeval-0.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="validate kubernetes YAML or JSON configuration files"
+HOMEPAGE="https://kubeval.com"
+SRC_URI="https://github.com/instrumenta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require the network
+RESTRICT="test"
+
+src_compile() {
+ emake TAG=v${PV} build
+}
+
+src_install() {
+ dobin bin/kubeval
+dodoc -r docs/*
+}
+
+src_test() {
+ emake TAG=v${PV} test
+}