summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-08 13:00:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-08 13:00:51 +0300
commite49c3f3e066b6ecf8e222a91dc57e71b3ae434de (patch)
treeca64f78b7ac4c017e7b9ded757d0b3962773d8fe /dev-util/pkgcheck
parentsys-apps/pkgcore: drop 0.12.19 (diff)
downloadgentoo-e49c3f3e066b6ecf8e222a91dc57e71b3ae434de.tar.gz
gentoo-e49c3f3e066b6ecf8e222a91dc57e71b3ae434de.tar.bz2
gentoo-e49c3f3e066b6ecf8e222a91dc57e71b3ae434de.zip
dev-util/pkgcheck: drop 0.10.22-r1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck')
-rw-r--r--dev-util/pkgcheck/Manifest1
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.22-r1.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-util/pkgcheck/Manifest b/dev-util/pkgcheck/Manifest
index 48af4d96b12d..f9e238fc0893 100644
--- a/dev-util/pkgcheck/Manifest
+++ b/dev-util/pkgcheck/Manifest
@@ -1,2 +1 @@
-DIST pkgcheck-0.10.22.tar.gz 566826 BLAKE2B 714eb92bd43b4c3f2319aecb343fe6580f754ba50ed6fa986faaedcba71d34f2834ca85d17c961d327c90081dc305febccfbe08dbc13a706d972e289271214e3 SHA512 45532faa169d42f3d5a94a17e83089d4789e7c3e26226f2e5441ba8816cd3610a9025cc392bb32d6d78f202354ab11117fbd07ec2550d7e3255c02c6cb96d98e
DIST pkgcheck-0.10.23.tar.gz 568903 BLAKE2B 8b00dc93d0c3f597f7397d2e7b3686d11b12da715d6e8071f1b02a8085061cbb2d7cb24bde6a73ef6e5d1459637cb78e536ce80a162f188a42739a434c62c397 SHA512 3bcdb91bf73cde60fd9fc2f5e470c5ccdfd7b3564e83192201b0fa1dc38265e1e0c7f7052039accbb62c55d816a6e89317d7d388c0cc3da3b4836475cb82bd03
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.22-r1.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.22-r1.ebuild
deleted file mode 100644
index 4e4cb79a4a27..000000000000
--- a/dev-util/pkgcheck/pkgcheck-0.10.22-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit elisp-common distutils-r1 optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcheck.git
- https://github.com/pkgcore/pkgcheck.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
- inherit pypi
-fi
-
-DESCRIPTION="pkgcore-based QA utility for ebuild repos"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="emacs"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND="
- >=dev-python/snakeoil-0.10.4[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.12.18[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
- dev-libs/tree-sitter
- dev-libs/tree-sitter-bash
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pathspec[${PYTHON_USEDEP}]
- >=dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
- emacs? (
- >=app-editors/emacs-24.1:*
- app-emacs/ebuild-mode
- app-emacs/flycheck
- )
-"
-BDEPEND="${RDEPEND}
- dev-python/wheel
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.10.21-fix-scm.patch"
-)
-
-SITEFILE="50${PN}-gentoo.el"
-
-distutils_enable_tests pytest
-
-export USE_SYSTEM_TREE_SITTER_BASH=1
-
-src_compile() {
- distutils-r1_src_compile
-
- if use emacs ; then
- pushd "${S}"/contrib/emacs >/dev/null || die
- elisp-compile *.el
- popd >/dev/null || die
- fi
-}
-
-python_install_all() {
- local DOCS=( NEWS.rst )
- [[ ${PV} == *9999 ]] || doman man/*
- distutils-r1_python_install_all
-
- if use emacs ; then
- elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- optfeature "Network check support" dev-python/requests
- optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}