summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-08-22 20:16:25 +0200
committerCraig Andrews <candrews@gentoo.org>2020-08-22 14:07:56 -0400
commitdedb3b3da2c941d8afabd170b227a541bcb38a27 (patch)
treea0620b91d60f0e5b25d954c107a35a5279485ea7 /dev-util/rocminfo/rocminfo-3.7.0.ebuild
parentdev-libs/rocr-runtime: Version bump to 3.7.0, fixed a typo (diff)
downloadgentoo-dedb3b3da2c941d8afabd170b227a541bcb38a27.tar.gz
gentoo-dedb3b3da2c941d8afabd170b227a541bcb38a27.tar.bz2
gentoo-dedb3b3da2c941d8afabd170b227a541bcb38a27.zip
dev-util/rocminfo: Version bump to 3.7.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17214 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo/rocminfo-3.7.0.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-3.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-3.7.0.ebuild b/dev-util/rocminfo/rocminfo-3.7.0.ebuild
new file mode 100644
index 000000000000..c993e808caf5
--- /dev/null
+++ b/dev-util/rocminfo/rocminfo-3.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocminfo-rocm-${PV}"
+fi
+
+DESCRIPTION="ROCm Application for Reporting System Info"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-libs/rocr-runtime"
+DEPEND="${RDEPEND}"