summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-29 21:40:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-29 21:49:57 +0200
commit68b485ff058af6b943ff6633724e3d2ddeb2c7b2 (patch)
tree4e89d123ab55d37a295f82c1b793c2edeedc5407 /dev-util/samurai/samurai-1.2-r1.ebuild
parentRevert "dev-util/samurai: Security revbump to fix mull pointer dereference" (diff)
downloadgentoo-68b485ff058af6b943ff6633724e3d2ddeb2c7b2.tar.gz
gentoo-68b485ff058af6b943ff6633724e3d2ddeb2c7b2.tar.bz2
gentoo-68b485ff058af6b943ff6633724e3d2ddeb2c7b2.zip
dev-util/samurai: Security revbump to fix null pointer dereference
Removed old Bug: https://bugs.gentoo.org/786951 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/samurai/samurai-1.2-r1.ebuild')
-rw-r--r--dev-util/samurai/samurai-1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/samurai/samurai-1.2-r1.ebuild b/dev-util/samurai/samurai-1.2-r1.ebuild
new file mode 100644
index 000000000000..ad8d964b12b3
--- /dev/null
+++ b/dev-util/samurai/samurai-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ninja-compatible build tool written in C"
+HOMEPAGE="https://github.com/michaelforney/samurai"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/michaelforney/samurai.git"
+else
+ SRC_URI="https://github.com/michaelforney/samurai/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="ISC Apache-2.0 MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-null_pointer_fix.patch" #786957
+)
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.md
+}