summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 06:00:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 06:47:58 +0100
commit257097c1ee9a18d5046345d6c15157c77712bd65 (patch)
tree881246670d57ee0525f9600f12d40b02d088bd16 /dev-util/stripe-mock
parentdev-python/platformdirs: Bump to 3.1.0 (diff)
downloadgentoo-257097c1ee9a18d5046345d6c15157c77712bd65.tar.gz
gentoo-257097c1ee9a18d5046345d6c15157c77712bd65.tar.bz2
gentoo-257097c1ee9a18d5046345d6c15157c77712bd65.zip
dev-util/stripe-mock: Bump to 0.152.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.152.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 98f52c1b62d0..9783fe6956b8 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.151.0.tar.gz 571906 BLAKE2B 3cd9bdf28b608506b649f2f93270ad7ea130afec9dd0e707537b588ce5ad7b7f16b51cfc10b7c3005552e2a8fe895ca2753d1136b04be1730602514110f96853 SHA512 a492be91e1e77b13862dc02d2520b958e3c12ed06318d02d642eca9dec6044b2685ac50982a421d798d615ed59da947eac0ffc2f3cc900a435ac1eb0a941a9c5
+DIST stripe-mock-0.152.0.tar.gz 577927 BLAKE2B 1a5bdfa7644a482837ad982b9c6512527910729dfbdd4eec6cb06be9fe51630e88c11c483162d25e21a897d8accbaae927581edc9731ed19e6e32d59938b621c SHA512 b9cb144b4b0ba3c09acfca6a7138cd87b9aa7f6bee824349ce5d3437b9daa14ea0f5b251fa3bbc6133908fa872868bd05582872aad12fd87a27941731abd6100
diff --git a/dev-util/stripe-mock/stripe-mock-0.152.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.152.0.ebuild
new file mode 100644
index 000000000000..ca0f4e60efa7
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.152.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}