summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-19 18:12:51 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-19 18:13:24 +0200
commit47dff7a7ef769aaae42ed5897e199adf9c749e33 (patch)
tree920f0e64ec60214915df21e009a5a6c6789d3d03 /dev-util/tkdiff/tkdiff-5.7.ebuild
parentapp-emacs/with-editor: fix SRC_URI (diff)
downloadgentoo-47dff7a7ef769aaae42ed5897e199adf9c749e33.tar.gz
gentoo-47dff7a7ef769aaae42ed5897e199adf9c749e33.tar.bz2
gentoo-47dff7a7ef769aaae42ed5897e199adf9c749e33.zip
dev-util/tkdiff: add 5.7
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-util/tkdiff/tkdiff-5.7.ebuild')
-rw-r--r--dev-util/tkdiff/tkdiff-5.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/tkdiff/tkdiff-5.7.ebuild b/dev-util/tkdiff/tkdiff-5.7.ebuild
new file mode 100644
index 000000000000..abcdfa83962b
--- /dev/null
+++ b/dev-util/tkdiff/tkdiff-5.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYP=${PN}-$(ver_rs 1- -)
+
+DESCRIPTION="Graphical front end to the diff program"
+HOMEPAGE="http://tkdiff.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${MYP}.zip"
+
+S="${WORKDIR}/${MYP}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-lang/tk"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ dobin tkdiff
+ dodoc CHANGELOG.txt
+}