summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-04 09:37:34 -0800
committerMatt Turner <mattst88@gentoo.org>2019-11-04 09:39:10 -0800
commitd720304b0505f3791eb088673aaba891b73b16d6 (patch)
tree6805f2388dcc3eac7f5f1140eaa90d6e8460d5f9 /dev-util/valgrind
parentdev-tex/circuit_macros: port to EAPI=7 (diff)
downloadgentoo-d720304b0505f3791eb088673aaba891b73b16d6.tar.gz
gentoo-d720304b0505f3791eb088673aaba891b73b16d6.tar.bz2
gentoo-d720304b0505f3791eb088673aaba891b73b16d6.zip
dev-util/valgrind: Fix test suite build failure on ppc
Closes: https://bugs.gentoo.org/685070 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch22
-rw-r--r--dev-util/valgrind/valgrind-3.15.0.ebuild2
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild2
3 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch b/dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
new file mode 100644
index 000000000000..44176658df74
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
@@ -0,0 +1,22 @@
+From beab8d9f8d65230567270331017184c8762faa42 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 4 Nov 2019 09:12:16 -0800
+Subject: [PATCH] Build ldst_multiple test with -fno-pie
+
+Bug: https://bugs.gentoo.org/685070
+---
+ none/tests/ppc32/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/none/tests/ppc32/Makefile.am b/none/tests/ppc32/Makefile.am
+index 11697c99a..222efd3f2 100644
+--- a/none/tests/ppc32/Makefile.am
++++ b/none/tests/ppc32/Makefile.am
+@@ -156,3 +156,4 @@ test_isa_2_07_part2_LDADD = -lm
+ test_tm_LDADD = -lm
+ test_touch_tm_LDADD = -lm
+
++ldst_multiple_CFLAGS = $(AM_CFLAGS) -fno-pie
+--
+2.23.0
+
diff --git a/dev-util/valgrind/valgrind-3.15.0.ebuild b/dev-util/valgrind/valgrind-3.15.0.ebuild
index b18a128859a5..d252d9dcee4c 100644
--- a/dev-util/valgrind/valgrind-3.15.0.ebuild
+++ b/dev-util/valgrind/valgrind-3.15.0.ebuild
@@ -31,6 +31,8 @@ src_prepare() {
# Respect CFLAGS, LDFLAGS
eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+
if [[ ${CHOST} == *-solaris* ]] ; then
# upstream doesn't support this, but we don't build with
# Sun/Oracle ld, we have a GNU toolchain, so get some things
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index b7152e95dc5e..41689a1904e1 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -31,6 +31,8 @@ src_prepare() {
# Respect CFLAGS, LDFLAGS
eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+
if [[ ${CHOST} == *-solaris* ]] ; then
# upstream doesn't support this, but we don't build with
# Sun/Oracle ld, we have a GNU toolchain, so get some things