summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-03 21:32:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-03 21:32:52 -0500
commit38dc3f64608c7103e830f91169d2e46ad1bca6a2 (patch)
treea691cdb05a20ba7e9ccc706a2ee8a4d239abad54 /dev-util
parentdev-perl/Template-Toolkit: add 3.10.0 (diff)
downloadgentoo-38dc3f64608c7103e830f91169d2e46ad1bca6a2.tar.gz
gentoo-38dc3f64608c7103e830f91169d2e46ad1bca6a2.tar.bz2
gentoo-38dc3f64608c7103e830f91169d2e46ad1bca6a2.zip
dev-util/gitlab-runner: add 15.2.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.2.1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index c9b6186e9b31..f51ed402f516 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -8,3 +8,5 @@ DIST gitlab-runner-15.1.1-deps.tar.xz 140961196 BLAKE2B b3818572b2b5c01c78290572
DIST gitlab-runner-15.1.1.tar.gz 1287440 BLAKE2B 0648132a2de277865d3899e460d0f444a26d3d827ee6efdf90abd195b243f31e138f57ca968c702089245e92763ab3cbb7e997fb8dc409a373689ed4e75016bc SHA512 538fc769e0aed90ffe4df9e2afe81b3c89f0c3d9ad9d48e52f12cde5df3b36326f054c1ab88c3d532cf573cdcd7a6e1733d3041cff133a665db5c91c4b8ddd0c
DIST gitlab-runner-15.2.0-deps.tar.xz 141451528 BLAKE2B a77b8ca5c1570fc80f2d9f2bf3ebd9291997cd7f017eb1eaefb68d7bdba219d9fd14fb86c313a8c4fdc8169d81488244905d971a9b7c8393000f85253fd69ae2 SHA512 0aca328527b8b769015ea8177e22c8e232dd840b6427bf6e7ae7e0acccdc3cc6630ad10c2bc3fc42729107509fd37eaa5441846aa5f1ce934d68786335b960a4
DIST gitlab-runner-15.2.0.tar.gz 1291980 BLAKE2B 06194f6dfba94a1d071b3f29f3065475b8a9c08669ee0ec43917340a54dcdf79843f43b3f7fbe2e57560184c58166d7c107ed465742cfff05163faaca7ef491f SHA512 74f6a8941909c189bbde534d1cf5e1b8a60f595fa6046ca98dd4fb3a9f7406f988dfb9b2c2a6c777813fb24e4f5c23975f74163f7d5584b553acc4ca28ec8331
+DIST gitlab-runner-15.2.1-deps.tar.xz 141242072 BLAKE2B 598850f3614772cad485a994ed156074c5f3aeb9b2bbf085fc9f77ded820d1facc6fafdc8b8fa9d763156cc15a454821113bfd47f2d943f2fb28723bc10a8cb7 SHA512 ac3f2b0272f9a6135c953b55e36623117c5e09c70ce88c2989fca4689eba699d12bffe6d5331876f942cfc69ae704b13f73f01ca9a681d02c113e2638420aad5
+DIST gitlab-runner-15.2.1.tar.gz 1291638 BLAKE2B 7f2c7100ab5a7e670f8d50ea9dccd5f96b23b4e7ba60f928d732edc3a5f50b10afcfe9ffb052c4242ee401a21a0ddfad14e398a6a133ac093f3bbab84b620b0e SHA512 ed165fd95094dd00450bd2ffbbe876235849fdd98ff0ffc6ce635a103f426d4380573ef8c71f5a40d115fa6fe7ec9416b1c7b780f1563e8b3d4c4a09c02519f7
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.2.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.2.1.ebuild
new file mode 100644
index 000000000000..eb76a2210290
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=32fc1585e
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}