summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-28 13:21:30 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-04 14:59:57 +0300
commit581b2049da1ea6a79ca40702b153f6a5553e6175 (patch)
treef52bff9481a0715d5dec2fc73f5933972bafe7d3 /dev-util
parentx11-wm/mutter: restrict sysprof-capture-3.35+ (diff)
downloadgentoo-581b2049da1ea6a79ca40702b153f6a5553e6175.tar.gz
gentoo-581b2049da1ea6a79ca40702b153f6a5553e6175.tar.bz2
gentoo-581b2049da1ea6a79ca40702b153f6a5553e6175.zip
dev-util/sysprof-capture: bump to 3.36.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.36.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index c718e91a09e2..153e4d5187a0 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1 +1,2 @@
DIST sysprof-3.34.1.tar.xz 372612 BLAKE2B 3a50a00f29866ae8bf03cc7a57b598e40a6a37ad88ac2159087e4f2a8a6a5cef09b345dc5332fb1df9036c4e159e98f19adda45588150b059af313878b9b554c SHA512 5f2d820935291a3b578222d5daa87b0a2f74cd16d14daca19065495be61cf7359f00f12f452a5c0b4e05dfeb94e2376017c2288cad92dc0c4bb9bca51b903d19
+DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.36.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.36.0.ebuild
new file mode 100644
index 000000000000..aeb811d08afa
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.36.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2
+ !=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # We want to ship org.gnome.Sysprof3.Profiler.xml here for the benefit of x11-wm/mutter
+ sed -i -e "s|if get_option('libsysprof')|if true|g" src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ )
+ meson_src_configure
+}