summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-08 04:17:19 +0100
committerSam James <sam@gentoo.org>2022-09-08 04:17:19 +0100
commitc9c6ed9355576ee71fee1988a08ec9258162a1d4 (patch)
treebe821644ea68f7656225e006d85f9cfeb767c538 /dev-util
parentnet-misc/openssh: fix implicit function declarations (diff)
downloadgentoo-c9c6ed9355576ee71fee1988a08ec9258162a1d4.tar.gz
gentoo-c9c6ed9355576ee71fee1988a08ec9258162a1d4.tar.bz2
gentoo-c9c6ed9355576ee71fee1988a08ec9258162a1d4.zip
dev-util/gperf: fix strncmp declaration
Closes: https://bugs.gentoo.org/869134 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gperf/files/gperf-3.1-strncmp-decl-mismatch.patch28
-rw-r--r--dev-util/gperf/gperf-3.1-r1.ebuild24
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/gperf/files/gperf-3.1-strncmp-decl-mismatch.patch b/dev-util/gperf/files/gperf-3.1-strncmp-decl-mismatch.patch
new file mode 100644
index 000000000000..67380fb0279c
--- /dev/null
+++ b/dev-util/gperf/files/gperf-3.1-strncmp-decl-mismatch.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/869134
+
+From 09844ce4ca3d5975469640cea9c5414d5c0baa44 Mon Sep 17 00:00:00 2001
+From: Bruno Haible <bruno@clisp.org>
+Date: Thu, 8 Sep 2022 04:45:03 +0200
+Subject: [PATCH] Fix a warning regarding strncmp.
+
+Reported by Sam James in <https://savannah.gnu.org/bugs/?63031>.
+
+* lib/getopt.c (strncmp): Declare with a prototype.
+--- a/lib/getopt.c
++++ b/lib/getopt.c
+@@ -194,7 +194,6 @@ static char *posixly_correct;
+ whose names are inconsistent. */
+
+ extern char *getenv ();
+-extern int strncmp ();
+
+ static char *
+ my_index (const char *str, int chr)
+@@ -209,6 +208,7 @@ my_index (const char *str, int chr)
+ }
+
+ extern int strcmp (const char *, const char *);
++extern int strncmp (const char *, const char *, size_t);
+ extern size_t strlen (const char *);
+
+ #endif /* not __GNU_LIBRARY__ */
diff --git a/dev-util/gperf/gperf-3.1-r1.ebuild b/dev-util/gperf/gperf-3.1-r1.ebuild
new file mode 100644
index 000000000000..bdabce4d841e
--- /dev/null
+++ b/dev-util/gperf/gperf-3.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A perfect hash function generator"
+HOMEPAGE="https://www.gnu.org/software/gperf/"
+SRC_URI="mirror://gnu/gperf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-strncmp-decl-mismatch.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e "/^CPPFLAGS /s:=:+=:" \
+ */Makefile.in || die #444078
+
+ default
+}