summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-01 23:10:59 +0000
committerSam James <sam@gentoo.org>2022-11-01 23:10:59 +0000
commit9ed1d27647a029173d731f95bb6da7a4e8baf08a (patch)
treed2863e7e6cbe03059205fc13e60c59331cd2bc0a /dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
parentnet-analyzer/nrpe: add 4.1.0 (diff)
downloadgentoo-9ed1d27647a029173d731f95bb6da7a4e8baf08a.tar.gz
gentoo-9ed1d27647a029173d731f95bb6da7a4e8baf08a.tar.bz2
gentoo-9ed1d27647a029173d731f95bb6da7a4e8baf08a.zip
dev-vcs/git-crypt: add missing OpenSSL dep
Bug: https://bugs.gentoo.org/805545 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild')
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild b/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..d1f3a018f685
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.6.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://github.com/AGWA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ dev-vcs/git
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${D}"/usr/bin || die
+ emake PREFIX="${D}"/usr install
+}