summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-08-06 22:08:12 +0200
committerSam James <sam@gentoo.org>2022-08-12 16:44:07 +0100
commit33c5ec8d6f509841240464f248514320800f1229 (patch)
treebcde32610ce6b2071ced6cdcaae847170e9fac62 /dev-vcs/git/git-2.37.2.ebuild
parentdev-vcs/git: add 2.37.2 (diff)
downloadgentoo-33c5ec8d6f509841240464f248514320800f1229.tar.gz
gentoo-33c5ec8d6f509841240464f248514320800f1229.tar.bz2
gentoo-33c5ec8d6f509841240464f248514320800f1229.zip
dev-vcs/git: allow disabling "safe.directory"
Add IUSE="+safe-directory" that when not enabled, makes the safe.directory configuration setting not take effect. The patch is meant to be the smallest change (in terms of lines of code) that would let the feature work for tests still. Bug: https://github.com/pkgcore/pkgcheck/issues/412 Bug: https://bugs.gentoo.org/857831 Bug: https://bugs.gentoo.org/838127 Bug: https://bugs.gentoo.org/838223 Bug: https://bugs.gentoo.org/838271 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/26762 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-2.37.2.ebuild')
-rw-r--r--dev-vcs/git/git-2.37.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-vcs/git/git-2.37.2.ebuild b/dev-vcs/git/git-2.37.2.ebuild
index 6b4a3f2ff057..70bd35f67fb0 100644
--- a/dev-vcs/git/git-2.37.2.ebuild
+++ b/dev-vcs/git/git-2.37.2.ebuild
@@ -51,7 +51,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc gnome-keyring +gpg highlight +iconv mediawiki mediawiki-experimental +nls +pcre perforce +perl +ppcsha1 selinux subversion tk +threads +webdav xinetd cvs test"
+IUSE="+blksha1 +curl cgi doc gnome-keyring +gpg highlight +iconv mediawiki mediawiki-experimental +nls +pcre perforce +perl +ppcsha1 +safe-directory selinux subversion tk +threads +webdav xinetd cvs test"
# Common to both DEPEND and RDEPEND
DEPEND="
@@ -253,6 +253,13 @@ src_prepare() {
"${FILESDIR}"/git-2.7.0-mediawiki-500pages.patch
)
fi
+ if ! use safe-directory ; then
+ # This patch neuters the "safe directory" detection.
+ # bugs #838271, #838223
+ PATCHES+=(
+ "${FILESDIR}"/git-2.37.2-unsafe-directory.patch
+ )
+ fi
default