summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-12-15 16:28:06 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-12-19 01:20:49 +0800
commitcae637be9cec73cd394c4ac02eac80e51ab93805 (patch)
tree2aa97f4c338edd345d86ec618e33644f22ebbcb7 /eclass/dist-kernel-utils.eclass
parentdev-python/hatchling: Bump to 1.21.0 (diff)
downloadgentoo-cae637be9cec73cd394c4ac02eac80e51ab93805.tar.gz
gentoo-cae637be9cec73cd394c4ac02eac80e51ab93805.tar.bz2
gentoo-cae637be9cec73cd394c4ac02eac80e51ab93805.zip
dist-kernel-utils.eclass: support loong in dist-kernel_get_image_path
The filenames to use are taken from upstream: https://github.com/torvalds/linux/blob/v6.6/arch/loongarch/boot/Makefile. Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'eclass/dist-kernel-utils.eclass')
-rw-r--r--eclass/dist-kernel-utils.eclass7
1 files changed, 7 insertions, 0 deletions
diff --git a/eclass/dist-kernel-utils.eclass b/eclass/dist-kernel-utils.eclass
index 62750d1721a2..67cb802151b2 100644
--- a/eclass/dist-kernel-utils.eclass
+++ b/eclass/dist-kernel-utils.eclass
@@ -87,6 +87,13 @@ dist-kernel_get_image_path() {
echo arch/${ARCH}/boot/Image.gz
fi
;;
+ loong)
+ if [[ ${KERNEL_EFI_ZBOOT} ]]; then
+ echo arch/loongarch/boot/vmlinuz.efi
+ else
+ echo arch/loongarch/boot/vmlinux.elf
+ fi
+ ;;
arm)
echo arch/arm/boot/zImage
;;