summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 07:34:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 16:28:59 +0200
commitabf991dec55ad184490689e7fbf8aab266329b80 (patch)
treed116db680afcd796a4003ab562025e82b64fb7ca /eclass/distutils-r1.eclass
parentx11-misc/xpad: Stabilize 5.8.0-r1 amd64, #907267 (diff)
downloadgentoo-abf991dec55ad184490689e7fbf8aab266329b80.tar.gz
gentoo-abf991dec55ad184490689e7fbf8aab266329b80.tar.bz2
gentoo-abf991dec55ad184490689e7fbf8aab266329b80.zip
distutils-r1.eclass: Use CYTHON_FORCE_REGEN=1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ec1dd08b197c..6835444d3c5f 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1828,6 +1828,10 @@ distutils-r1_run_phase() {
if [[ ${DISTUTILS_EXT} ]]; then
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
+ # always generate .c files from .pyx files to ensure we get latest
+ # bug fixes from Cython (this works only when setup.py is using
+ # cythonize() but it's better than nothing)
+ local -x CYTHON_FORCE_REGEN=1
fi
# How to build Python modules in different worlds...