summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/bomberclone
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/bomberclone')
-rw-r--r--games-action/bomberclone/Manifest1
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8.ebuild50
-rw-r--r--games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch20
-rw-r--r--games-action/bomberclone/metadata.xml8
4 files changed, 79 insertions, 0 deletions
diff --git a/games-action/bomberclone/Manifest b/games-action/bomberclone/Manifest
new file mode 100644
index 000000000000..2f5378b24c24
--- /dev/null
+++ b/games-action/bomberclone/Manifest
@@ -0,0 +1 @@
+DIST bomberclone-0.11.8.tar.bz2 7966452 SHA256 2f6993ee4a63e8cea51f9605e35de4b4ec12a5abafd25309c313ddb0fba35230 SHA512 a5e52db43f7f508993231ec13bb2705f60e25cfc21d15c17d9b422c6fc948dc14cc8c4519acfac2e9b7b32a3072dc3a521fbf28b2150a86cfb4099ced72ab79b WHIRLPOOL 89ecc1ce9f18342ea0bf4cb099e26eed8dc2ebddf71c75356f522a0a2b5d593d1525234c104d441f4d3073efb01e78fe234b0a7aabb81baa236df6c5133084c4
diff --git a/games-action/bomberclone/bomberclone-0.11.8.ebuild b/games-action/bomberclone/bomberclone-0.11.8.ebuild
new file mode 100644
index 000000000000..155c9d2cb052
--- /dev/null
+++ b/games-action/bomberclone/bomberclone-0.11.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils autotools games
+
+DESCRIPTION="BomberMan clone with network game support"
+HOMEPAGE="http://www.bomberclone.de/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86"
+IUSE="X"
+
+DEPEND=">=media-libs/libsdl-1.1.0
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]
+ X? ( x11-libs/libXt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecvs_clean
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ $(use_with X x) \
+ --datadir="${GAMES_DATADIR_BASE}"
+ sed -i \
+ -e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:${GAMES_DATADIR}/:" \
+ config.h \
+ || die
+}
+
+src_install() {
+ dogamesbin src/${PN}
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/{gfx,maps,player,tileset,music}
+ find "${D}" -name "Makefile*" -exec rm -f '{}' +
+
+ dodoc AUTHORS ChangeLog README TODO
+ doicon data/pixmaps/bomberclone.png
+ make_desktop_entry bomberclone Bomberclone
+ prepgamesdirs
+}
diff --git a/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch b/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch
new file mode 100644
index 000000000000..d534df6192b6
--- /dev/null
+++ b/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch
@@ -0,0 +1,20 @@
+--- configure.in.old 2011-06-18 18:23:48.633605738 +0200
++++ configure.in 2011-06-18 18:26:26.910628408 +0200
+@@ -33,7 +33,7 @@
+ )
+
+ CFLAGS="$SDL_CFLAGS $CFLAGS"
+- LIBS="$SDL_LIBS $LIBS"
++ LIBS="$SDL_LIBS $LIBS -lm"
+
+
+ dnl Checks for header files.
+@@ -84,7 +84,7 @@
+ CFLAGS="$CFLAGS -Wall"
+ AC_MSG_WARN(Disable Warning as Error Treatment)
+ else
+- CFLAGS="$CFLAGS -Wall -Werror"
++ CFLAGS="$CFLAGS -Wall"
+ fi
+
+
diff --git a/games-action/bomberclone/metadata.xml b/games-action/bomberclone/metadata.xml
new file mode 100644
index 000000000000..2c5c4b0302ac
--- /dev/null
+++ b/games-action/bomberclone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">bomberclone</remote-id>
+ </upstream>
+</pkgmetadata>