summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-07-26 14:45:51 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:18 +0300
commit4ab99fc2150d104bfec7b288ef4aa43212c3eb65 (patch)
tree4eb2812a22db6d0cc3fd9cbc4eae078989283458 /games-action
parentdev-cpp/prometheus-cpp: New package (diff)
downloadgentoo-4ab99fc2150d104bfec7b288ef4aa43212c3eb65.tar.gz
gentoo-4ab99fc2150d104bfec7b288ef4aa43212c3eb65.tar.bz2
gentoo-4ab99fc2150d104bfec7b288ef4aa43212c3eb65.zip
games-action/minetest: Add prometheus client support
Closes: https://bugs.gentoo.org/733984 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16840 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/minetest/metadata.xml1
-rw-r--r--games-action/minetest/minetest-5.3.0.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/games-action/minetest/metadata.xml b/games-action/minetest/metadata.xml
index 8ca84936bcba..5cd60f0a8711 100644
--- a/games-action/minetest/metadata.xml
+++ b/games-action/minetest/metadata.xml
@@ -44,6 +44,7 @@
<use>
<flag name="client">Build Minetest client</flag>
<flag name="leveldb">Enable LevelDB backend</flag>
+ <flag name="prometheus">Enable prometheus client support</flag>
<flag name="redis">Enable redis backend via <pkg>dev-libs/hiredis</pkg></flag>
<flag name="server">Build Minetest server</flag>
<flag name="spatial">Enable SpatialIndex AreaStore backend
diff --git a/games-action/minetest/minetest-5.3.0.ebuild b/games-action/minetest/minetest-5.3.0.ebuild
index 94e307d76447..b954c7f0fa33 100644
--- a/games-action/minetest/minetest-5.3.0.ebuild
+++ b/games-action/minetest/minetest-5.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+ CC-BY-SA-3.0 OFL-1.1 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+client +curl doc +leveldb ncurses nls postgres redis +server +sound spatial test +truetype"
+IUSE="+client +curl doc +leveldb ncurses nls postgres prometheus redis +server +sound spatial test +truetype"
REQUIRED_USE="|| ( client server )"
RESTRICT="!test? ( test )"
@@ -42,6 +42,7 @@ RDEPEND="
ncurses? ( sys-libs/ncurses:0= )
nls? ( virtual/libintl )
postgres? ( >=dev-db/postgresql-9.5:= )
+ prometheus? ( dev-cpp/prometheus-cpp )
redis? ( dev-libs/hiredis:= )
server? (
acct-group/minetest
@@ -87,6 +88,7 @@ src_configure() {
-DENABLE_LEVELDB=$(usex leveldb)
-DENABLE_LUAJIT=1
-DENABLE_POSTGRESQL=$(usex postgres)
+ -DENABLE_PROMETHEUS=$(usex prometheus)
-DENABLE_REDIS=$(usex redis)
-DENABLE_SPATIAL=$(usex spatial)
-DENABLE_SOUND=$(usex sound)