summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-10 14:18:01 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-10 14:19:59 +0100
commit86f76904c98b70ae6cd5d78717e0306d27c1c9b0 (patch)
tree0c2c850a707902ee34b18794a1d208d6132bfd91 /games-action
parentdev-ruby/stringio: Stabilize 3.0.4 hppa, #904123 (diff)
downloadgentoo-86f76904c98b70ae6cd5d78717e0306d27c1c9b0.tar.gz
gentoo-86f76904c98b70ae6cd5d78717e0306d27c1c9b0.tar.bz2
gentoo-86f76904c98b70ae6cd5d78717e0306d27c1c9b0.zip
games-action/minetest: disable upstream update checker for new configs
User with existing ~/.minetest/minetest.conf have to change this by hand so the ebuild provides instructions for how to do it. Suggested-by: Jaak Ristioja <jaak@ristioja.ee> Closes: https://bugs.gentoo.org/904122 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/minetest/minetest-5.7.0-r2.ebuild (renamed from games-action/minetest/minetest-5.7.0-r1.ebuild)10
1 files changed, 10 insertions, 0 deletions
diff --git a/games-action/minetest/minetest-5.7.0-r1.ebuild b/games-action/minetest/minetest-5.7.0-r2.ebuild
index 6e2aecdf7ed8..c34a0a5a97d6 100644
--- a/games-action/minetest/minetest-5.7.0-r1.ebuild
+++ b/games-action/minetest/minetest-5.7.0-r2.ebuild
@@ -99,6 +99,7 @@ src_configure() {
-DENABLE_SOUND=$(usex sound)
-DENABLE_SYSTEM_GMP=1
-DENABLE_SYSTEM_JSONCPP=1
+ -DENABLE_UPDATE_CHECKER=no
-DRUN_IN_PLACE=0
)
@@ -138,4 +139,13 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
+
+ elog "Since 5.7.0-r2 new ${PN} configurations no longer check if newer versions are available upstream,"
+ elog "a feature unnecessary when ${PN} is installed using distro packages."
+ elog "To disable this check for existing configurations open the file ~/.minetest/minetest.conf"
+ elog "in a text editor while ${PN} is not running, locate the keyword 'update_last_checked',"
+ elog "and change that line to say:"
+ elog
+ elog " update_last_checked = disabled"
+ elog
}