summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-06-17 15:18:33 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-06-17 15:20:05 +0100
commit979e9e1e2d51a484ef5b08959f1b8c6960c32bf7 (patch)
treeb43bbe3b05b08a4163ae5acca6a2912ea763eb4a /games-action
parentprofiles: Mask games-action/psychonauts-gog on musl and no-multilib (diff)
downloadgentoo-979e9e1e2d51a484ef5b08959f1b8c6960c32bf7.tar.gz
gentoo-979e9e1e2d51a484ef5b08959f1b8c6960c32bf7.tar.bz2
gentoo-979e9e1e2d51a484ef5b08959f1b8c6960c32bf7.zip
games-action/psychonauts-gog: New package
Closes: https://bugs.gentoo.org/435830 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/psychonauts-gog/Manifest1
-rw-r--r--games-action/psychonauts-gog/metadata.xml14
-rw-r--r--games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/games-action/psychonauts-gog/Manifest b/games-action/psychonauts-gog/Manifest
new file mode 100644
index 000000000000..1099011ecc8a
--- /dev/null
+++ b/games-action/psychonauts-gog/Manifest
@@ -0,0 +1 @@
+DIST gog_psychonauts_2.0.0.4.sh 4424617772 BLAKE2B 4102a7e23f71857c969349be3eb5b5fa4780d02ec92945a0be13098af4fa30d04fe4294e0fd5b3bd64dfe731a252ee4bcb73c07ca15df4dc532f26e12ed0335d SHA512 5f8cbcbd2eecab66f0a3bc555a6850536dd124fe720d6fe7eba0a56964978b045daac14630ec2e2f9129a3c6cf263baf5cbe65b15f08bc5cd5f754f35b3629a9
diff --git a/games-action/psychonauts-gog/metadata.xml b/games-action/psychonauts-gog/metadata.xml
new file mode 100644
index 000000000000..6366a89a523f
--- /dev/null
+++ b/games-action/psychonauts-gog/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Psychic Odyssey Through the Mental Worlds of Misfits, Monsters, and
+ Mind Readers. This classic action/adventure platformer from acclaimed
+ developers Double Fine Productions follows the story of a young psychic
+ named Razputin.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
new file mode 100644
index 000000000000..2c30c1827211
--- /dev/null
+++ b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker wrapper xdg
+
+MY_PN="Psychonauts"
+
+DESCRIPTION="A mind-bending platforming adventure from Double Fine Productions"
+HOMEPAGE="https://www.doublefine.com/games/psychonauts"
+SRC_URI="gog_${MY_PN,,}_${PV}.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch strip"
+
+BDEPEND="app-arch/unzip"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+ >=sys-devel/gcc-3.4
+ sys-libs/glibc
+ !games-action/${MY_PN,,}
+"
+
+S="${WORKDIR}/data/noarch"
+dir="/opt/${MY_PN,,}"
+QA_PREBUILT="${dir#/}/*"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from:"
+ elog " https://www.gog.com/game/${MY_PN,,}"
+ elog "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe game/${MY_PN}
+ make_wrapper ${MY_PN,,} "${dir}"/${MY_PN}
+
+ insinto "${dir}"
+ doins -r game/{icon.bmp,WorkResource/,*.pkg}
+
+ newicon -s 256 support/icon.png ${MY_PN,,}.png
+ make_desktop_entry ${MY_PN,,} ${MY_PN} ${MY_PN,,}
+
+ dodoc \
+ docs/"Psychonauts Manual Win.pdf" \
+ game/Documents/Readmes/*.txt
+}