summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/blobby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/blobby')
-rw-r--r--games-arcade/blobby/Manifest1
-rw-r--r--games-arcade/blobby/blobby-0.9c.ebuild49
-rw-r--r--games-arcade/blobby/files/blobby-0.9c-gcc47.patch66
-rw-r--r--games-arcade/blobby/metadata.xml8
4 files changed, 124 insertions, 0 deletions
diff --git a/games-arcade/blobby/Manifest b/games-arcade/blobby/Manifest
new file mode 100644
index 000000000000..6ddf0d43217a
--- /dev/null
+++ b/games-arcade/blobby/Manifest
@@ -0,0 +1 @@
+DIST blobby2-linux-0.9c.tar.gz 2290384 SHA256 e3ed8f92c70e16d24f109b6f0f4dccc25656a88780eb1a348d1223edcb7fc937 SHA512 741eed708f6688af179e19cecc17cb1e0cdbd6a9e2680fbfd8093ca171c0593474ec1bd11c1704e6e275ae8693c72c8f2f93fdc9ec7863dcda5999a76b0002e2 WHIRLPOOL 04e5b7786290cd43abcfd25099c9dd338a4405e5fd8c796c366b6a8e456bbcc2930a906a8a4c6cb796aacf9f4716f3913b70f7ccdc35b025c0e924a30ccc4f63
diff --git a/games-arcade/blobby/blobby-0.9c.ebuild b/games-arcade/blobby/blobby-0.9c.ebuild
new file mode 100644
index 000000000000..4128a0d5f763
--- /dev/null
+++ b/games-arcade/blobby/blobby-0.9c.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils eutils games
+
+DESCRIPTION="A beach ball game with blobs of goo"
+HOMEPAGE="http://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-games/physfs-2[zip]
+ media-libs/libsdl[sound,joystick,opengl,video,X]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ app-arch/zip" #406667
+
+S=${WORKDIR}/${PN}-beta-${PV}
+
+src_prepare() {
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR}/${PN}:" data/CMakeLists.txt || die
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR/\/usr\/}/${PN}:" src/main.cpp || die
+ sed -i -e "/DESTINATION/s:bin:${GAMES_BINDIR}:" src/CMakeLists.txt || die
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO" cmake-utils_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+}
diff --git a/games-arcade/blobby/files/blobby-0.9c-gcc47.patch b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
new file mode 100644
index 000000000000..be873b7af0d1
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
@@ -0,0 +1,66 @@
+--- src/raknet/BinarySearchTree.h.old 2012-06-21 09:09:08.389412319 +0200
++++ src/raknet/BinarySearchTree.h 2012-06-21 09:10:39.830991876 +0200
+@@ -338,12 +338,12 @@
+ if ( current->left == 0 )
+ left_height = 0;
+ else
+- left_height = height( current->left );
++ left_height = this->height( current->left );
+
+ if ( current->right == 0 )
+ right_height = 0;
+ else
+- right_height = height( current->right );
++ right_height = this->height( current->right );
+
+ if ( right_height - left_height == 2 )
+ {
+@@ -371,7 +371,7 @@
+ if ( current == this->root )
+ break;
+
+- current = find_parent( *( current->item ) );
++ current = this->find_parent( *( current->item ) );
+
+ }
+ }
+@@ -400,7 +400,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->right ) > height( A->left );
++ return this->height( A->right ) > this->height( A->left );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -409,7 +409,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->left ) > height( A->right );
++ return this->height( A->left ) > this->height( A->right );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -446,8 +446,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->right;
+
+ if ( A )
+@@ -510,8 +510,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->left;
+
+ if ( A )
diff --git a/games-arcade/blobby/metadata.xml b/games-arcade/blobby/metadata.xml
new file mode 100644
index 000000000000..54fc8e0db93d
--- /dev/null
+++ b/games-arcade/blobby/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">blobby</remote-id>
+ </upstream>
+</pkgmetadata>