summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-08-09 13:26:42 +0200
committerPacho Ramos <pacho@gentoo.org>2018-08-09 13:26:42 +0200
commit8c87dd5ae9375deedbd89afc256c69746e4b4dc7 (patch)
tree837e09f5b4485e5011add7c193f16fb0fa2e351e /games-arcade/methane/methane-1.5.1-r1.ebuild
parentgames-action/abuse: Prevent segfault at start (diff)
downloadgentoo-8c87dd5ae9375deedbd89afc256c69746e4b4dc7.tar.gz
gentoo-8c87dd5ae9375deedbd89afc256c69746e4b4dc7.tar.bz2
gentoo-8c87dd5ae9375deedbd89afc256c69746e4b4dc7.zip
games-arcade/methane: Drop games.eclass, apply Fedora fixes.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'games-arcade/methane/methane-1.5.1-r1.ebuild')
-rw-r--r--games-arcade/methane/methane-1.5.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/methane/methane-1.5.1-r1.ebuild b/games-arcade/methane/methane-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..acf9163b76e7
--- /dev/null
+++ b/games-arcade/methane/methane-1.5.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+#inherit eutils flag-o-matic games
+inherit desktop
+
+DESCRIPTION="Port from an old amiga game"
+HOMEPAGE="http://methane.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+
+ # From Fedora
+ eapply "${FILESDIR}"/${P}-gcc5.patch
+ eapply "${FILESDIR}"/${P}-fullscreen.patch
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share:" \
+ sources/target.cpp || die
+
+ # fix weird parallel make issue wrt #450422
+ mkdir build || die
+ #append-cxxflags -Wno-narrowing # build with gcc5 (bug #573788)
+}
+
+src_install() {
+ dobin methane
+ insinto /usr/share/${PN}
+ doins resources/*
+ newicon docs/puff.gif ${PN}.gif
+ make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
+ HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
+}