summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/tuxanci
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/tuxanci')
-rw-r--r--games-arcade/tuxanci/Manifest1
-rw-r--r--games-arcade/tuxanci/metadata.xml13
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429.ebuild73
-rw-r--r--games-arcade/tuxanci/tuxanci-99999999.ebuild73
4 files changed, 160 insertions, 0 deletions
diff --git a/games-arcade/tuxanci/Manifest b/games-arcade/tuxanci/Manifest
new file mode 100644
index 000000000000..b60c10355e16
--- /dev/null
+++ b/games-arcade/tuxanci/Manifest
@@ -0,0 +1 @@
+DIST tuxanci-20110429.tar.xz 4283540 SHA256 60dc0cc5d2eafd54874d193ae796758b387029ad8806758a8c0f2a76649023df SHA512 72305be823981699e9ac38c090dda2baafd45bd36554eba65bd438646e0b0b8a3ab17a7516610db17e225292c39e0cdabb383193f8b07d2d31d638483feafeea WHIRLPOOL 94a90ffc9cef732dbc64dc6c2f44253a5aa2859c74920363436f4e8e4584921ae794a42299188a008de953585c37e5a778b5dc561a09d732759da705f0215945
diff --git a/games-arcade/tuxanci/metadata.xml b/games-arcade/tuxanci/metadata.xml
new file mode 100644
index 000000000000..66221545ba2f
--- /dev/null
+++ b/games-arcade/tuxanci/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>scarabeus@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="sound">Enable sound</flag>
+ <flag name="physfs">Use <pkg>dev-games/physfs</pkg> instead of
+ <pkg>dev-libs/libzip</pkg> to load compressed data</flag>
+</use>
+</pkgmetadata>
diff --git a/games-arcade/tuxanci/tuxanci-20110429.ebuild b/games-arcade/tuxanci/tuxanci-20110429.ebuild
new file mode 100644
index 000000000000..f204b93dc846
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-20110429.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[[ ${PV} = 9999* ]] && GIT="git-2"
+EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
+
+inherit games cmake-utils ${GIT}
+
+DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
+HOMEPAGE="http://www.tuxanci.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
+
+# >=x11-libs/cairo-1.8.8[X,svg]
+RDEPEND="
+ !dedicated? (
+ >=media-libs/fontconfig-2.7.0
+ media-libs/libsdl[X,opengl?]
+ media-libs/sdl-ttf[X]
+ >=media-libs/sdl-image-1.2.10[png]
+ sound? (
+ >=media-libs/sdl-mixer-1.2.11[vorbis]
+ )
+ )
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ $(cmake-utils_use_with sound AUDIO)
+ $(cmake-utils_use_build dedicated SERVER)
+ $(cmake-utils_use_with nls)
+ $(cmake-utils_use_with physfs)
+ $(cmake-utils_use_with opengl)
+ $(cmake-utils_use_enable ipv6)
+ $(cmake-utils_use debug DEVELOPER)
+ )
+
+ mycmakeargs+=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
+ "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
+ "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
+ "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
+ "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
+ "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ prepgamesdirs
+}
diff --git a/games-arcade/tuxanci/tuxanci-99999999.ebuild b/games-arcade/tuxanci/tuxanci-99999999.ebuild
new file mode 100644
index 000000000000..db6290cd595d
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-99999999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[[ ${PV} = 9999* ]] && GIT="git-2"
+EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
+
+inherit games cmake-utils ${GIT}
+
+DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
+HOMEPAGE="http://www.tuxanci.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.${PN}.org/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
+
+# >=x11-libs/cairo-1.8.8[X,svg]
+RDEPEND="
+ !dedicated? (
+ >=media-libs/fontconfig-2.7.0
+ media-libs/libsdl[X,opengl?]
+ media-libs/sdl-ttf[X]
+ >=media-libs/sdl-image-1.2.10[png]
+ sound? (
+ >=media-libs/sdl-mixer-1.2.11[vorbis]
+ )
+ )
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ $(cmake-utils_use_with sound AUDIO)
+ $(cmake-utils_use_build dedicated SERVER)
+ $(cmake-utils_use_with nls)
+ $(cmake-utils_use_with physfs)
+ $(cmake-utils_use_with opengl)
+ $(cmake-utils_use_enable ipv6)
+ $(cmake-utils_use debug DEVELOPER)
+ )
+
+ mycmakeargs+=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
+ "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
+ "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
+ "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
+ "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
+ "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ prepgamesdirs
+}