summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-12 04:25:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-12 04:59:39 -0400
commitcfaf1b89e80f2667a8958860f3674e2aff9745ee (patch)
tree51e120bf4e0bb09b740b33176b2a7f48bc428bac /games-arcade
parentnet-misc/ytfzf: add 2.6.0 (diff)
downloadgentoo-cfaf1b89e80f2667a8958860f3674e2aff9745ee.tar.gz
gentoo-cfaf1b89e80f2667a8958860f3674e2aff9745ee.tar.bz2
gentoo-cfaf1b89e80f2667a8958860f3674e2aff9745ee.zip
games-arcade/cdogs-sdl: add 1.4.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/cdogs-sdl/Manifest1
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-1.4.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/Manifest b/games-arcade/cdogs-sdl/Manifest
index f2469138cc62..228e930e5362 100644
--- a/games-arcade/cdogs-sdl/Manifest
+++ b/games-arcade/cdogs-sdl/Manifest
@@ -1 +1,2 @@
DIST cdogs-sdl-1.4.1.tar.gz 35799934 BLAKE2B 67fe75575c478a3e38a7ba70060dc329c98b1b96912216dbf4a7d71784222485efff645349c2d9db72184947f16dcbd73ba52e61a03ad9b4c341650ab9ce144c SHA512 de8d181fed78d68ebeed44b408210252c616db7aaf80d472ea2ce3981fca8792c0226bb0006af014bc9151e2c1ba1b94708441e4c039ba2648cef3e41b31feda
+DIST cdogs-sdl-1.4.2.tar.gz 35799287 BLAKE2B 76891785f44a6abbe309976b6e706d019cc4c4444c3a58cf83859ad7518a2931eb208b7305ea5d09b2692961d5fd39ff2a8aafce820a9920820646bb1ab81261 SHA512 36bea4eb1f11c4abc752695455f30b6f76b6c3aab02d57ece0f8a77d116c7810a5ebcc211de441a6487bc43d977dfab84ffa56b4aa5a8a45cdff5e2810c4fddf
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-1.4.2.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-1.4.2.ebuild
new file mode 100644
index 000000000000..55dd0eccdce1
--- /dev/null
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-1.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Classic overhead run-and-gun game"
+HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
+SRC_URI="https://github.com/cxong/cdogs-sdl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD-2 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0 CC0-1.0 WTFPL-2 XMAME public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl2[haptic,opengl]
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[mp3,vorbis,wav]
+ net-libs/enet:1.3="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-cmake.patch
+)
+
+src_configure() {
+ filter-lto #858527
+
+ local mycmakeargs=(
+ -DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/ # trailing / is needed
+ -DBUILD_EDITOR=OFF
+ -DUSE_SHARED_ENET=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc doc/{AUTHORS,original_readme.txt}
+
+ # CREDITS is used at runtime, rest is licenses or duplicates
+ find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
+}