summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-09 21:21:05 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-11 13:46:35 +0100
commit11268d540cf2fa3b4644ba4ac83820a46a0e1e8c (patch)
tree4b8a039a01f0187dd4c6861d96e2ba592fc89920 /games-board/gnome-chess/gnome-chess-3.22.2.ebuild
parentx11-libs/gtksourceview: add gtksourceview-3.22.1.ebuild (diff)
downloadgentoo-11268d540cf2fa3b4644ba4ac83820a46a0e1e8c.tar.gz
gentoo-11268d540cf2fa3b4644ba4ac83820a46a0e1e8c.tar.bz2
gentoo-11268d540cf2fa3b4644ba4ac83820a46a0e1e8c.zip
games-board/gnome-chess: add gnome-chess-3.22.2.ebuild
Simple bump, no relevant changes https://git.gnome.org/browse/gnome-chess/diff/?id=3.22.2&id2=3.22.0 Closes: https://github.com/gentoo/gentoo/pull/2792 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'games-board/gnome-chess/gnome-chess-3.22.2.ebuild')
-rw-r--r--games-board/gnome-chess/gnome-chess-3.22.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/gnome-chess/gnome-chess-3.22.2.ebuild b/games-board/gnome-chess/gnome-chess-3.22.2.ebuild
new file mode 100644
index 000000000000..a087aa94a659
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.22.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 vala readme.gentoo-r1
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32:2
+ >=x11-libs/gtk+-3.19:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+ need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}