summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/goatee-gtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/goatee-gtk')
-rw-r--r--games-board/goatee-gtk/Manifest1
-rw-r--r--games-board/goatee-gtk/goatee-gtk-0.3.0.ebuild55
-rw-r--r--games-board/goatee-gtk/metadata.xml15
3 files changed, 71 insertions, 0 deletions
diff --git a/games-board/goatee-gtk/Manifest b/games-board/goatee-gtk/Manifest
new file mode 100644
index 000000000000..384d4c29e1f3
--- /dev/null
+++ b/games-board/goatee-gtk/Manifest
@@ -0,0 +1 @@
+DIST goatee-gtk-0.3.0.tar.gz 60381 SHA256 bb9f65956e3bb13d03e42dcbd65c39c40f2d225b881da47d5744b95b34beba71 SHA512 f4af3e1871d8e8c1b2c8df135b58019e2c0574eae165655af34e73c8e18a10ebb8ab0ac095c14a58f3e28250880e4539086e2841b0ed88575ce704de00ce4ada WHIRLPOOL 9e454177f38ef7e6d2e131b562411b239cbd176c20eacd9a95a27f8353931589c25c3feff2a5356576f0e8097c14fe6dbc8b1cdb704759d712be6fed808ed107
diff --git a/games-board/goatee-gtk/goatee-gtk-0.3.0.ebuild b/games-board/goatee-gtk/goatee-gtk-0.3.0.ebuild
new file mode 100644
index 000000000000..0692db54f980
--- /dev/null
+++ b/games-board/goatee-gtk/goatee-gtk-0.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal eutils games
+
+DESCRIPTION="A monadic take on a 2,500-year-old board game - GTK+ UI"
+HOMEPAGE="http://khumba.net/projects/goatee"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/goatee-0.3:=[profile?] <dev-games/goatee-0.4:=[profile?]
+ >=dev-haskell/cairo-0.12:=[profile?] <dev-haskell/cairo-0.13:=[profile?]
+ >=dev-haskell/gtk-0.12:2=[profile?] <dev-haskell/gtk-0.13:2=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-libs/gmp-5:=
+ virtual/libffi:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3 )
+"
+
+pkg_setup() {
+ games_pkg_setup
+ haskell-cabal_pkg_setup
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --bindir="${GAMES_BINDIR}"
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+}
+
+src_install() {
+ haskell-cabal_src_install
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ games_pkg_postinst
+}
diff --git a/games-board/goatee-gtk/metadata.xml b/games-board/goatee-gtk/metadata.xml
new file mode 100644
index 000000000000..2ad2762eb324
--- /dev/null
+++ b/games-board/goatee-gtk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>haskell</herd>
+ <longdescription>
+ Goatee is a Go library and game editor, written in Haskell. It provides a
+ GUI for recording, studying, and editing game records. Underneath this is a
+ portable library for manipulating SGF files to build UIs and tools. Goatee
+ aims to be full-featured by supporting all of the SGF spec and allowing for
+ full and easy customization of the game records you create.
+
+ This package is the GTK+ UI.
+ </longdescription>
+</pkgmetadata>