summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/scid/scid-4.6.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/scid/scid-4.6.2.ebuild')
-rw-r--r--games-board/scid/scid-4.6.2.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/games-board/scid/scid-4.6.2.ebuild b/games-board/scid/scid-4.6.2.ebuild
new file mode 100644
index 000000000000..45c9e22a21fb
--- /dev/null
+++ b/games-board/scid/scid-4.6.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils toolchain-funcs gnome2-utils python-any-r1 games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}.zip
+ mirror://sourceforge/scid/spelling.zip
+ mirror://sourceforge/scid/ratings.zip
+ mirror://sourceforge/scid/photos.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-lang/tk:0
+ dev-tcltk/tkimg
+ >=sys-libs/zlib-1.1.3"
+RDEPEND="${CDEPEND}
+ !games-board/chessdb"
+DEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/unzip"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ default
+ mv scid-src ${P} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix engines/togaII1.2.1a/src/Makefile
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ tcl/start.tcl || die
+ sed -i \
+ -e "/COMPILE.*testzlib/s:\$var(COMPILE):$(tc-getCXX):" \
+ configure || die
+ gzip ../ratings.ssp || die
+ python_fix_shebang .
+}
+
+src_configure() {
+ # configure is not an autotools script
+ ./configure \
+ COMPILE="$(tc-getCXX)" \
+ LINK="$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE="" \
+ BINDIR="${GAMES_BINDIR}" \
+ SHAREDIR="${GAMES_DATADIR}/${PN}" || die
+}
+
+src_compile() {
+ emake all_scid
+}
+
+src_install() {
+ emake DESTDIR="${D}" install_scid
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds
+
+ dodoc ChangeLog TODO
+ dohtml help/*.html
+
+ newicon -s scalable svg/scid_app.svg ${PN}.svg
+ make_desktop_entry scid Scid
+
+ doins ../spelling.ssp ../ratings.ssp.gz ../*.spf
+ newins ../scidlet40k.sbk scidlet.sbk
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ elog "To enable speech, emerge dev-tcltk/snack"
+ elog "To enable Xfcc support, emerge dev-tcltk/tdom"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}