summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-11 20:28:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-11 20:34:34 +0200
commit301bb3c6662e57aa9ae873118be8c2cb90b37266 (patch)
tree053b70c97c517e8b59588c05cdbe1bc80a016a92 /games-board/tetzle/tetzle-2.1.3.ebuild
parentgames-board/peg-e: Drop old (diff)
downloadgentoo-301bb3c6662e57aa9ae873118be8c2cb90b37266.tar.gz
gentoo-301bb3c6662e57aa9ae873118be8c2cb90b37266.tar.bz2
gentoo-301bb3c6662e57aa9ae873118be8c2cb90b37266.zip
games-board/tetzle: 2.1.3 version bump
Fixes qmake with Qt 5.11. Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'games-board/tetzle/tetzle-2.1.3.ebuild')
-rw-r--r--games-board/tetzle/tetzle-2.1.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/tetzle/tetzle-2.1.3.ebuild b/games-board/tetzle/tetzle-2.1.3.ebuild
new file mode 100644
index 000000000000..bc3518d35a8f
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="A jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="https://gottcode.org/tetzle/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ eqmake5
+}
+
+src_install(){
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}