summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-19 06:58:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-19 07:35:34 -0400
commit5766d7228b9df5837563d68d79dc13021f3c356d (patch)
tree87b61304fb67704ece35a89eda45c6445dd7f068 /games-emulation
parentgames-emulation/pcsx2: reduce postinst messages (diff)
downloadgentoo-5766d7228b9df5837563d68d79dc13021f3c356d.tar.gz
gentoo-5766d7228b9df5837563d68d79dc13021f3c356d.tar.bz2
gentoo-5766d7228b9df5837563d68d79dc13021f3c356d.zip
games-emulation/pcsx2: add 1.7.5033
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/Manifest1
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.5033.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index ddff241a7cae..ea922468de55 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1,5 +1,6 @@
DIST pcsx2-1.6.0.tar.gz 17963332 BLAKE2B d1370fd089e1f8716a3365b9f499fef9418c4a9464e701cf0dbac8296cf59a2c6fc9b85ed680c514d8128da7b5c47aa8a067d48cac9eb0482ef2ba5f9234e60e SHA512 0a3e01a25384719fc72b636a1e9cf1cd966d0c978c1c3adfb46d6b3f76f43a25f90ef63d27a1d8092cdf444c5dc7560ce807ca81908d11ade9715e7eaaad6253
DIST pcsx2-1.7.4940.tar.gz 12433815 BLAKE2B ee59fab55015182e8c809acd0317916b070a5f8f4c3d8a162639eb5119d10beb83c9dae1242394e00694360d3270483ddc2de103b9f31e155a2b26f41957edec SHA512 be4ed47f531cf173da9471e4a30a60f6f2ecf021f34358d94c17705da644bf9db7560d4b3e990828307161e97efa8d551353fafcb57b009be0e26e423acdf3f6
+DIST pcsx2-1.7.5033.tar.xz 15811448 BLAKE2B ac1fa9e405aafc03c194e0a032102af19b1c7b64114aa64523982bcb1c519c8a1c888c4d681a63d68fb744c4cc1999f2feb4ff71757eb645d9d5826813c34c2b SHA512 ba62725beeb7f51cc6c6da746384d33b6435d3a06e5f06844b09a6399171befd0e4099b277fa5c91d09a2f5399270511e53c34aaee43afee975152344a5127a6
DIST pcsx2-fast_float-32d21dcecb.tar.gz 76108 BLAKE2B 7a4e8e3bb67387c03912e5f7035ba3fab1aeaa119b36ebdeb14c45069b3270270a8b87de2774ec325d8ed2ef0604a3d3762432d42f1e026a213990ac39341e10 SHA512 2cbdc5b05ab7c19e20b4e34959b90d1fa866d4ba239ec0a4c434cd33bddfb1cb6f1da467b0a525f5a4887c9b1860e975fe074aca0d9e211f0fc7bc6402d3601e
DIST pcsx2-fmt-b6f4ceaed0.tar.gz 826246 BLAKE2B 74a4784bd1842d3afa4023efb8f74ad53b4d5b4676c5529f2c7b516db568f91d945804db20b425fececfbf10a44a1fdf39a94f88d6f40339328ceb263e15b37f SHA512 805424979dbed28ba0a48f69928a14d122de50f21dcadb97f852dcc415ab8a7a30fcf2eb90c06f006c54cbea00fcfe449d340cbb40e6a0454fffbc009fbe25e5
DIST pcsx2-glslang-c9706bdda0.tar.gz 3433325 BLAKE2B f2449a6c8b05e47367164d09036ae2302f0f28ec83c2e2f401426f52fbd4edf55f717f01eea2cbfe7554e1004b89ffdebc34ec21a95809fcbc719f69e65e8487 SHA512 5ff0902e95592525b2671788bf27717c85d0876b31e96374eff5128f9bf7caf93bb636e4d5e1916a5d641715a780172308403bd49305d9a07cf66358d7e6407c
diff --git a/games-emulation/pcsx2/pcsx2-1.7.5033.ebuild b/games-emulation/pcsx2/pcsx2-1.7.5033.ebuild
new file mode 100644
index 000000000000..98a2f8f00c10
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-1.7.5033.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop fcaps flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2.git"
+else
+ # formerly was attempting to unbundle most, but upstream dropped every
+ # checks for alternatively using system's and keeping this up has become
+ # unmaintainable, and to simplify now also using tarballs with submodules
+ SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+ KEYWORDS="-* ~amd64"
+fi
+
+DESCRIPTION="PlayStation 2 emulator"
+HOMEPAGE="https://pcsx2.net/"
+
+LICENSE="
+ GPL-3+ Apache-2.0 BSD BSD-2 BSD-4 Boost-1.0 CC0-1.0 GPL-2+
+ ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain
+"
+SLOT="0"
+IUSE="alsa cpu_flags_x86_sse4_1 jack pulseaudio sndio test vulkan wayland"
+REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
+RESTRICT="!test? ( test )"
+
+# dlopen: qtsvg, vulkan-loader, wayland
+COMMON_DEPEND="
+ app-arch/xz-utils
+ dev-libs/libaio
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ media-libs/libglvnd
+ media-libs/libpng:=
+ >=media-libs/libsdl2-2.28.2[haptic,joystick]
+ media-video/ffmpeg:=
+ net-libs/libpcap
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib:=
+ virtual/libudev:=
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-libs/libpulse )
+ sndio? ( media-sound/sndio:= )
+ vulkan? ( media-libs/vulkan-loader )
+ wayland? ( dev-libs/wayland )
+"
+# patches is a optfeature but always pull given PCSX2 complaints if it
+# is missing and it is fairly small (installs a ~1.5MB patches.zip)
+RDEPEND="
+ ${COMMON_DEPEND}
+ >=games-emulation/pcsx2_patches-0_p20230917
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.3468-cubeb-automagic.patch
+ "${FILESDIR}"/${PN}-1.7.3773-lto.patch
+ "${FILESDIR}"/${PN}-1.7.4667-flags.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ ${PV} != 9999 ]]; then
+ sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}-gentoo'"/' \
+ -i cmake/Pcsx2Utils.cmake || die
+ fi
+}
+
+src_configure() {
+ if use vulkan; then
+ # for bundled glslang (bug #858374)
+ append-flags -fno-strict-aliasing
+
+ # odr violations in pcsx2's vulkan code, disabling as a safety for now
+ filter-lto
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=no
+ -DDISABLE_BUILD_DATE=yes
+ -DENABLE_TESTS=$(usex test)
+ -DUSE_LINKED_FFMPEG=yes
+ -DUSE_VTUNE=no
+ -DUSE_VULKAN=$(usex vulkan)
+ -DWAYLAND_API=$(usex wayland)
+ -DX11_API=yes # X libs are currently hard-required either way
+
+ # sse4.1 is the bare minimum required, -m is required at build time
+ # (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)
+ # https://github.com/PCSX2/pcsx2/pull/4329
+ -DARCH_FLAG=-msse4.1
+
+ # not packaged due to bug #885471, but still disable for no automagic
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libbacktrace=yes
+
+ # bundled cubeb flags, see media-libs/cubeb and cubeb-automagic.patch
+ -DCHECK_ALSA=$(usex alsa)
+ -DCHECK_JACK=$(usex jack)
+ -DCHECK_PULSE=$(usex pulseaudio)
+ -DCHECK_SNDIO=$(usex sndio)
+ -DLAZY_LOAD_LIBS=no
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build unittests
+}
+
+src_install() {
+ insinto /usr/lib/${PN}
+ doins -r "${BUILD_DIR}"/bin/.
+
+ fperms +x /usr/lib/${PN}/pcsx2-qt
+ dosym -r /usr/lib/${PN}/pcsx2-qt /usr/bin/${PN}
+
+ newicon bin/resources/icons/AppIconLarge.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^^}
+
+ dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,debugger.txt}
+
+ use !test || rm "${ED}"/usr/lib/${PN}/*_test || die
+}
+
+pkg_postinst() {
+ fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
+
+ if [[ ${REPLACING_VERSIONS##* } ]] &&
+ ver_test ${REPLACING_VERSIONS##* } -lt 1.7; then
+ elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, and is"
+ elog "notably now a 64bit build using Qt6. Just-in-case it is recommended"
+ elog "to backup configs, save states, and memory cards before using."
+ elog
+ elog "The executable was also renamed from 'PCSX2' to 'pcsx2'."
+ fi
+}