summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-28 23:40:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-28 23:41:06 +0100
commit666b24e06e2139ddb98ae3e478b92bee924c0148 (patch)
tree3275598258d171c6703b98f4119b1cf6898e111a /games-emulation
parentmedia-tv/v4l-utils: Take over as maintainer (diff)
downloadgentoo-666b24e06e2139ddb98ae3e478b92bee924c0148.tar.gz
gentoo-666b24e06e2139ddb98ae3e478b92bee924c0148.tar.bz2
gentoo-666b24e06e2139ddb98ae3e478b92bee924c0148.zip
games-emulation/fceux: respect CC and CXX
While at it update to EAPI=7. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/fceux-2.2.3-r1.ebuild57
-rw-r--r--games-emulation/fceux/files/fceux-2.2.2-warnings.patch2
2 files changed, 57 insertions, 2 deletions
diff --git a/games-emulation/fceux/fceux-2.2.3-r1.ebuild b/games-emulation/fceux/fceux-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..67080c8115f9
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.2.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 desktop scons-utils toolchain-funcs
+
+DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="http://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk logo +lua +opengl"
+
+RDEPEND="
+ lua? ( dev-lang/lua:0 )
+ media-libs/libsdl[opengl?,video]
+ logo? ( media-libs/gd[png] )
+ opengl? ( virtual/opengl )
+ gtk? ( x11-libs/gtk+:3 )
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.2.2-warnings.patch)
+
+src_prepare() {
+ default
+
+ tc-export CC CXX
+}
+
+src_compile() {
+ escons \
+ GTK=0 \
+ CREATE_AVI=1 \
+ SYSTEM_LUA=1 \
+ SYSTEM_MINIZIP=1 \
+ GTK3=$(usex gtk 1 0) \
+ LOGO=$(usex logo 1 0) \
+ OPENGL=$(usex opengl 1 0) \
+ LUA=$(usex lua 1 0)
+}
+
+src_install() {
+ dobin bin/fceux
+
+ doman documentation/fceux.6
+ docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
+ dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
+ rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
+ make_desktop_entry fceux FCEUX
+ doicon fceux.png
+}
diff --git a/games-emulation/fceux/files/fceux-2.2.2-warnings.patch b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
index f0af4631abda..1d6c3ba46319 100644
--- a/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
+++ b/games-emulation/fceux/files/fceux-2.2.2-warnings.patch
@@ -1,4 +1,3 @@
-diff -ru fceux-2.2.2.orig/src/input.cpp fceux-2.2.2/src/input.cpp
--- fceux-2.2.2.orig/src/input.cpp 2013-06-15 15:44:11.000000000 -0400
+++ fceux-2.2.2/src/input.cpp 2014-12-31 01:32:46.302001912 -0500
@@ -1161,7 +1161,7 @@
@@ -10,7 +9,6 @@ diff -ru fceux-2.2.2.orig/src/input.cpp fceux-2.2.2/src/input.cpp
SwapSaveState();
}
-diff -ru fceux-2.2.2.orig/src/state.cpp fceux-2.2.2/src/state.cpp
--- fceux-2.2.2.orig/src/state.cpp 2013-09-18 19:03:59.000000000 -0400
+++ fceux-2.2.2/src/state.cpp 2014-12-31 01:33:11.453155054 -0500
@@ -1048,7 +1048,7 @@