summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-19 16:12:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-19 17:24:15 +0200
commit9b6fed56089051db8c8f3b485503a8f3d9327401 (patch)
tree08fd7747324ce15142fca08208b22386a689acbc /games-emulation
parentdev-python/pytest-httpx: Remove old (diff)
downloadgentoo-9b6fed56089051db8c8f3b485503a8f3d9327401.tar.gz
gentoo-9b6fed56089051db8c8f3b485503a8f3d9327401.tar.bz2
gentoo-9b6fed56089051db8c8f3b485503a8f3d9327401.zip
games-emulation/m64py: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/m64py/Manifest1
-rw-r--r--games-emulation/m64py/m64py-0.3.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index b61826677dda..0da58f930ead 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1,2 +1,3 @@
+DIST mupen64plus-ui-python-0.3.0.gh.tar.gz 11387994 BLAKE2B 5b76290fc3b2d64c65b19362e8f14f732f7c2fb22cff2bf921222ccc342c514cb10b2cde8899282e55884e4ff89ddba0befa90adc92328d4248fef694689f675 SHA512 67160e7bbce5a9a4a9f39b63bf1fda013b0ef537a5916e123c15a7c7e29e2e44e2438ea9b7fd5f8b24bc11114ac0bcf48fd11386ce70e4e3e1c51e1b8d15383b
DIST mupen64plus-ui-python-90093ce3b353ff0fbe3277eb5d75130debdf0fab.gh.tar.gz 14669607 BLAKE2B 98384d2fd8c0adda12500006e40aa50856cf74b71d8cd6b95a9717e864ebb85b76f8b3b719b84adca29a5269b8c5af447c144fb15f4e061ae44ff9d6cd097345 SHA512 75756367306a951110ed7b37aec875627d6e807e70d51518b771c4592c7e6bf7acc0e4e18531b33cabc2317c78b333e556f47e06227d8af0a767ca350c9685ee
DIST mupen64plus-ui-python-e24679436a93e8aae0aa664dc4b2dea40d8236c1.gh.tar.gz 14669412 BLAKE2B 08232599557503d606db9e44bdd6dbb30b3fa125bfd9b9bcc2cbc4b6ea71b567f5af4338d03e7580707db522249d9426ec4d64dc1e941a43076b2d21bc974b67 SHA512 2ba865041827a7f47d5151db6123abd62c964c024c14356aa5434619736b19ce150178d536cff1c84e93d0544823e173c67c0f08054c13e01f085912a9b8c2c6
diff --git a/games-emulation/m64py/m64py-0.3.0.ebuild b/games-emulation/m64py/m64py-0.3.0.ebuild
new file mode 100644
index 000000000000..feb0e0b1edbe
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 qmake-utils xdg-utils
+
+MY_P=mupen64plus-ui-python-${PV}
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="
+ https://m64py.sourceforge.net/
+ https://github.com/mupen64plus/mupen64plus-ui-python/
+"
+SRC_URI="
+ https://github.com/mupen64plus/mupen64plus-ui-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z rar"
+
+RDEPEND="
+ dev-python/PyQt6[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2
+ 7z? (
+ app-arch/p7zip
+ )
+ rar? (
+ || (
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ app-arch/unrar
+ app-arch/rar
+ )
+ )
+"
+BDEPEND="
+ dev-qt/qttools:6
+"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_ || die
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+ _EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x PATH=$(qt6_get_bindir):${PATH}
+ distutils-r1_python_compile
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}