summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-05 17:43:45 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-05 18:26:25 +0100
commitd96bb099141b0aa85965362b7991e86047f33477 (patch)
tree8ac521d84b0e9c9390c222c26372750adde4f504 /games-emulation
parentdev-vcs/git-lfs: remove old version (diff)
downloadgentoo-d96bb099141b0aa85965362b7991e86047f33477.tar.gz
gentoo-d96bb099141b0aa85965362b7991e86047f33477.tar.bz2
gentoo-d96bb099141b0aa85965362b7991e86047f33477.zip
games-emulation/dolphin: update to EAPI=7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 55392d47b0fd..706fa7cec8de 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PLOCALES="ar ca cs da de el en es fa fr hr hu it ja ko ms nb nl pl pt pt_BR ro ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit cmake-utils desktop gnome2-utils l10n pax-utils
+inherit cmake desktop xdg-utils l10n pax-utils
if [[ ${PV} == *9999 ]]
then
@@ -71,7 +71,7 @@ RDEPEND="${RDEPEND}
media-libs/vulkan-loader"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Remove all the bundled libraries that support system-installed
# preference. See CMakeLists.txt for conditional 'add_subdirectory' calls.
@@ -146,13 +146,18 @@ src_configure() {
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)
-DUSE_SHARED_ENET=ON
-DUSE_UPNP=$(usex upnp)
+
+ # Undo cmake-utils.eclass's defaults.
+ # All dolphin's libraries are private
+ # and rely on circular dependency resolution.
+ -DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc Readme.md
if use doc; then
@@ -167,9 +172,9 @@ src_install() {
pkg_postinst() {
# Add pax markings for hardened systems
pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}