summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Swanson <reiver@improbability.net>2021-11-22 12:25:38 +0000
committerMichał Górny <mgorny@gentoo.org>2021-11-22 14:20:44 +0100
commitd40a8862de0bfb211fe8f5066471c5e7f4b5b376 (patch)
treed5982010cd81cd793c96c3a81ba160ed8c08f9e1 /games-engines/scummvm/scummvm-9999.ebuild
parentnet-misc/pmsvn: treeclean (diff)
downloadgentoo-d40a8862de0bfb211fe8f5066471c5e7f4b5b376.tar.gz
gentoo-d40a8862de0bfb211fe8f5066471c5e7f4b5b376.tar.bz2
gentoo-d40a8862de0bfb211fe8f5066471c5e7f4b5b376.zip
games-engines/scummvm: Bump to version 2.5.0
Signed-off-by: Alan Swanson <reiver@improbability.net> Closes: https://github.com/gentoo/gentoo/pull/23035 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-engines/scummvm/scummvm-9999.ebuild')
-rw-r--r--games-engines/scummvm/scummvm-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-engines/scummvm/scummvm-9999.ebuild b/games-engines/scummvm/scummvm-9999.ebuild
index cf7685a08e01..9f70736f67ee 100644
--- a/games-engines/scummvm/scummvm-9999.ebuild
+++ b/games-engines/scummvm/scummvm-9999.ebuild
@@ -11,14 +11,14 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/scummvm/scummvm"
else
- SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+ SRC_URI="https://downloads.scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}/${PN}-${P}"
fi
LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
-IUSE="a52 aac alsa debug flac fluidsynth fribidi glew +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
+IUSE="a52 aac alsa debug flac fluidsynth fribidi gif glew +gtk jpeg lua mpeg2 mp3 +net opengl png sndio speech theora truetype unsupported vorbis zlib"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND="
@@ -29,6 +29,7 @@ RDEPEND="
flac? ( media-libs/flac )
fluidsynth? ( media-sound/fluidsynth:= )
fribidi? ( dev-libs/fribidi )
+ gif? ( media-libs/giflib )
gtk? (
dev-libs/glib:2
x11-libs/gtk+:3
@@ -102,6 +103,7 @@ src_configure() {
$(use_enable flac)
$(usex fluidsynth '' --disable-fluidsynth)
$(use_enable fribidi)
+ $(use_enable gif)
$(use opengl && use_enable glew)
$(use_enable gtk)
$(use_enable jpeg)