summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ezquake-bin/ezquake-bin-2.2.ebuild')
-rw-r--r--games-fps/ezquake-bin/ezquake-bin-2.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild b/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
new file mode 100644
index 000000000000..8b2bfd2793c0
--- /dev/null
+++ b/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_FULL_PV=1.9.3
+MY_PN="${PN/-bin/}"
+DESCRIPTION="Quakeworld client with mqwcl functionality and many more features"
+HOMEPAGE="http://ezquake.sf.net/"
+SRC_URI="
+ amd64? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_64.${MY_FULL_PV}.tar.gz
+ mirror://sourceforge/${MY_PN}/${MY_PN}_linux64_${PV}.tar.gz )
+ x86? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_${MY_FULL_PV}.tar.gz
+ mirror://sourceforge/${MY_PN}/${MY_PN}_linux32_${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip mirror"
+IUSE="cdinstall"
+
+DEPEND="cdinstall? ( games-fps/quake1-data )"
+RDEPEND="${DEPEND}
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm"
+
+S=${WORKDIR}/${MY_PN}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/ezquake*"
+
+src_unpack() {
+ unpack ${A}
+ if use amd64; then
+ mv ${MY_PN}_linux-x86_64.${MY_FULL_PV} "${MY_PN}"
+ mv ezquake-gl_linux-x64.glx "${MY_PN}"/ezquake-gl.glx
+ else
+ mv ${MY_PN}_linux-x86.${MY_FULL_PV} "${MY_PN}"
+ mv ezquake-gl_linux-x86.glx "${MY_PN}"/ezquake-gl.glx
+ fi
+}
+
+src_install() {
+ exeinto "${dir}"
+ insinto "${dir}"
+
+ doexe ezquake-gl.glx
+ doins -r ezquake qw
+ dosym "${GAMES_DATADIR}"/quake1/id1 "${dir}"/id1
+ games_make_wrapper ezquake-gl.glx ./ezquake-gl.glx "${dir}" "${dir}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "NOTE that this client doesn't include .pak files. You *should*"
+ elog "enable \"cdinstall\" flag or install quake1-demodata with the symlink use flag."
+ elog "You can also copy the files from your Quake1 CD to"
+ elog " ${dir}/quake1/id1 (all names lowercase)"
+ elog ""
+ elog "You may also want to check:"
+ elog " http://fuhquake.quakeworld.nu - complete howto on commands and variables"
+ elog " http://equake.quakeworld.nu - free package containing various files"
+ fi
+}