summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 00:35:23 -0400
committerSam James <sam@gentoo.org>2024-03-25 09:20:48 +0000
commit0012503b0da5ab81ce03243d03f4a14767ac76c4 (patch)
tree3a6253704562f5911e6f9321eff360c4eb0ea7ed /games-fps
parentgames-fps/doomsday: add github / bugs-to upstream metadata (diff)
downloadgentoo-0012503b0da5ab81ce03243d03f4a14767ac76c4.tar.gz
gentoo-0012503b0da5ab81ce03243d03f4a14767ac76c4.tar.bz2
gentoo-0012503b0da5ab81ce03243d03f4a14767ac76c4.zip
games-fps/doomsday: mark as LTO-unsafe
Currently working on reporting an upstream bug. Four different websites including sourceforge and github but the only place for submitting bugs is a self-hosted redmine that has disabled registration. Closes: https://bugs.gentoo.org/858743 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomsday/doomsday-2.3.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-fps/doomsday/doomsday-2.3.1.ebuild b/games-fps/doomsday/doomsday-2.3.1.ebuild
index e47741325506..26cd12c34b90 100644
--- a/games-fps/doomsday/doomsday-2.3.1.ebuild
+++ b/games-fps/doomsday/doomsday-2.3.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake python-any-r1 qmake-utils readme.gentoo-r1 xdg
+inherit cmake flag-o-matic python-any-r1 qmake-utils readme.gentoo-r1 xdg
DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
HOMEPAGE="https://www.dengine.net"
@@ -55,6 +55,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858743
+ #
+ # Currently working on reporting an upstream bug. Four different websites
+ # including sourceforge and github but the only place for submitting bugs
+ # is a self-hosted redmine that has disabled registration.
+ filter-lto
+
local mycmakeargs=(
-DDENG_ASSIMP_EMBEDDED=OFF
-DDENG_ENABLE_DISPLAYMODE=$(usex display-mode)