summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Pavlov <t.x00100x.t@yandex.ru>2024-01-24 16:55:01 +0300
committerFlorian Schmaus <flow@gentoo.org>2024-01-28 20:42:27 +0100
commit45f40d193555eec4837e705aedc1cf86013808cf (patch)
treee75153995f1b2926814f7ee1217e55abd22df9ff /games-fps
parentdev-python/pytest-xdist: Fix retention-related test failures (diff)
downloadgentoo-45f40d193555eec4837e705aedc1cf86013808cf.tar.gz
gentoo-45f40d193555eec4837e705aedc1cf86013808cf.tar.bz2
gentoo-45f40d193555eec4837e705aedc1cf86013808cf.zip
games-fps/serioussam: Bump to version 1.10.6d. Update License.
Rename serioussam-1.10.6.ebuild to serioussam-1.10.6c.ebuild Update license for serioussam-1.10.6c.ebuild libvorbis(BSD License) sources and headers not need for build 1.10.6c Add new ebuild serioussam-1.10.6d.ebuild libvorbis(BSD License) sources and headers not need for build 1.10.6d zlib(ZLIB License) sources and headers not need for build 1.10.6d Signed-off-by: Alexander Pavlov <t.x00100x.t@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/34880 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/serioussam/Manifest1
-rw-r--r--games-fps/serioussam/serioussam-1.10.6c.ebuild (renamed from games-fps/serioussam/serioussam-1.10.6.ebuild)10
-rw-r--r--games-fps/serioussam/serioussam-1.10.6d.ebuild106
3 files changed, 112 insertions, 5 deletions
diff --git a/games-fps/serioussam/Manifest b/games-fps/serioussam/Manifest
index eb7ea315651a..a3473b88b03b 100644
--- a/games-fps/serioussam/Manifest
+++ b/games-fps/serioussam/Manifest
@@ -1 +1,2 @@
DIST serioussam-1.10.6c.tar.gz 47908208 BLAKE2B 90af9f8c11b474ce0e114c3390e1afd5c746c1b2ca4e61bd6085f1dc42f6f73981cc4434ff8fdcc1306178ae9d2707026765a3a1da006d5adb841d2d314a4214 SHA512 de1ba536c84977d1e7335833b8a2080b13a22ca25efba88363972dceb4bcbfda1db448de42d262fa003fe9df393327509e76afc3cc501f96ed6495d29b74b6bb
+DIST serioussam-1.10.6d.tar.gz 47922084 BLAKE2B b035df25f897e498e8e6bf4707c3003e0aeb79eff8d0067b5887716acd3630640e2d599434288635f4ae7d6aeb522a0e814c0b5acb64dc6166d7b7487e9ee88c SHA512 1a71e1277f6d2e7d0d059a15c51877d3d838e1c97ea6d8c61cdeb4ff0a4c2640be6a412db2c099b78d15b657d3b0bf8f324416d9258f7867fee6cf54923a542d
diff --git a/games-fps/serioussam/serioussam-1.10.6.ebuild b/games-fps/serioussam/serioussam-1.10.6c.ebuild
index 5f7794528412..79d84e4d8acf 100644
--- a/games-fps/serioussam/serioussam-1.10.6.ebuild
+++ b/games-fps/serioussam/serioussam-1.10.6c.ebuild
@@ -13,13 +13,13 @@ GN2="serioussamse"
DESCRIPTION="Linux port of Serious Sam Classic with Vulkan support"
HOMEPAGE="https://github.com/tx00100xt/SeriousSamClassic-VK"
-SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}c.tar.gz -> ${P}c.tar.gz"
-S="${WORKDIR}/SeriousSamClassic-VK-${PV}c"
+SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/SeriousSamClassic-VK-${PV}"
-MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN1}"
-MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN2}"
+MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}/${MY_PN1}"
+MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}/${MY_PN2}"
-LICENSE="GPL-2 BSD ZLIB"
+LICENSE="GPL-2 ZLIB"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="alsa pipewire vulkan"
diff --git a/games-fps/serioussam/serioussam-1.10.6d.ebuild b/games-fps/serioussam/serioussam-1.10.6d.ebuild
new file mode 100644
index 000000000000..4df47b2386ee
--- /dev/null
+++ b/games-fps/serioussam/serioussam-1.10.6d.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+MY_PN1="SamTFE"
+MY_PN2="SamTSE"
+# Game name
+GN1="serioussam"
+GN2="serioussamse"
+
+DESCRIPTION="Linux port of Serious Sam Classic with Vulkan support"
+HOMEPAGE="https://github.com/tx00100xt/SeriousSamClassic-VK"
+SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/SeriousSamClassic-VK-${PV}"
+
+MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}/${MY_PN1}"
+MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}/${MY_PN2}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pipewire vulkan"
+
+RDEPEND="
+ games-fps/serioussam-tfe-data
+ games-fps/serioussam-tse-data
+ media-libs/libsdl2[video,joystick,opengl]
+ media-libs/libvorbis
+ sys-libs/zlib
+ alsa? (
+ >=media-libs/libsdl2-2.0.6[alsa,sound]
+ )
+ pipewire? (
+ >=media-libs/libsdl2-2.0.6[pipewire,sound]
+ )
+ vulkan? (
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ media-libs/libsdl2[video,joystick,opengl,vulkan]
+ )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ app-alternatives/lex
+ app-alternatives/yacc
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ einfo "Remove Win32 stuff..."
+ rm -rf "${MY_CONTENT1}"/Tools.Win32 || die "Failed to remove stuff Win32"
+ rm -rf "${MY_CONTENT2}"/Tools.Win32 || die "Failed to remove stuff Win32"
+
+ einfo "Setting build type Release..."
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DUSE_SYSTEM_INSTALL=ON
+ -DUSE_SYSTEM_VULKAN=$(usex vulkan ON OFF)
+ -DUSE_ASM=$(usex x86 OFF ON)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local dir1="/usr/share/${GN1}"
+ local dir2="/usr/share/${GN2}"
+ local dir3="/usr/share/applications"
+ cmake_src_install
+
+ # install man pages
+ mv "${S}"/man/gentoo/serioussam-vk.1 "${S}"/man/gentoo/serioussam.1 \
+ || die "Failed move man pages"
+ doman "${S}"/man/gentoo/serioussam.1
+
+ # removing repo stuff
+ rm -fr "${MY_CONTENT1}/Sources" && rm -fr "${MY_CONTENT2}/Sources" \
+ || die "Failed to remove Sources"
+ rm -f "${MY_CONTENT1}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussam icon and desktop file"
+ rm -f "${MY_CONTENT2}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussamse icon and desktop file"
+ rm -f "${ED}${dir3}/${GN1}.desktop" "${ED}${dir3}/${GN2}.desktop" \
+ || die "Failed to remove desktop file"
+
+ # moving repo content (Scripts, Data, Settings ...)
+ cp -fr "${MY_CONTENT1}"/* "${ED}${dir1}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+ cp -fr "${MY_CONTENT2}"/* "${ED}${dir2}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+
+ make_desktop_entry ${GN1} "Serious Sam The First Encounter" ${GN1}
+ make_desktop_entry ${GN2} "Serious Sam The Second Encounter" ${GN2}
+}
+
+pkg_postinst() {
+ elog " Look at:"
+ elog " man serioussam"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information on the first launch of the game"
+}