summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 22:59:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:10 +0100
commit55529e0658274200a9c56e7330c7843e10afa25a (patch)
tree0cfbdebe7eaf9a15e675208240351febb9a2b5f3 /games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
parentgames-kids/memonix: EAPI-7 bump, cmake.eclass, https, drop eutils (diff)
downloadgentoo-55529e0658274200a9c56e7330c7843e10afa25a.tar.gz
gentoo-55529e0658274200a9c56e7330c7843e10afa25a.tar.bz2
gentoo-55529e0658274200a9c56e7330c7843e10afa25a.zip
games-misc/ballerburg: EAPI-7 bump, cmake.eclass, https
Use nomancompress.patch and drop src_install. Need to set CMAKE_MAKEFILE_GENERATOR=emake, otherwise ninja fails with: ninja: error: '/var/tmp/portage/games-misc/ballerburg-1.2.0-r1/work/ballerburg-1.2.0/src/*.c', needed by 'po/ballerburg.pot', missing and no known rule to make it Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild')
-rw-r--r--games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
index e4a987433010..6b15169bd6a3 100644
--- a/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
+++ b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake
DESCRIPTION="Linux port of the classical Atari ST game Ballerburg"
-HOMEPAGE="http://baller.tuxfamily.org/"
-SRC_URI="http://download.tuxfamily.org/baller/${P}.tar.gz"
+HOMEPAGE="https://baller.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/baller/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
@@ -16,14 +17,11 @@ KEYWORDS="~amd64"
DEPEND="media-libs/libsdl"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
+
src_configure() {
local mycmakeargs=(
-DDOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- gunzip "${ED}usr/share/man/man6/ballerburg.6.gz" || die
+ cmake_src_configure
}