summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2024-04-09 23:15:14 -0500
committerErik Mackdanz <stasibear@gentoo.org>2024-04-09 23:47:07 -0500
commit35cb495fa06fdb252bb06f285e5a3180965466e8 (patch)
tree5e5274fdaa973868b32e4ba8a58db9e1825567fa /games-roguelike
parentgames-roguelike/stone-soup: drop 0.31.0_pre20231027 (diff)
downloadgentoo-35cb495fa06fdb252bb06f285e5a3180965466e8.tar.gz
gentoo-35cb495fa06fdb252bb06f285e5a3180965466e8.tar.bz2
gentoo-35cb495fa06fdb252bb06f285e5a3180965466e8.zip
games-roguelike/stone-soup: reorder vars to satisfy pkgcheck
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r103.ebuild10
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.26.1-r2.ebuild10
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.27.1-r1.ebuild10
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.28.0-r1.ebuild14
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.29.1.ebuild10
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.30.1.ebuild10
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.31.0.ebuild10
7 files changed, 44 insertions, 30 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r103.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r103.ebuild
index 2fd6ee339cb2..0b712dda89b3 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r103.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r103.ebuild
@@ -23,18 +23,21 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.25"
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.25"
SRC_URI="
https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
@@ -83,7 +86,6 @@ BDEPEND="
app-alternatives/yacc
"
-S=${WORKDIR}/${MY_P}/source
PATCHES=(
"${FILESDIR}"/make.patch
"${FILESDIR}"/rltiles-make.patch
diff --git a/games-roguelike/stone-soup/stone-soup-0.26.1-r2.ebuild b/games-roguelike/stone-soup/stone-soup-0.26.1-r2.ebuild
index 7429d5fa73d8..6e8f74d68955 100644
--- a/games-roguelike/stone-soup/stone-soup-0.26.1-r2.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.26.1-r2.ebuild
@@ -23,18 +23,21 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.26"
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.26"
SRC_URI="
https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
@@ -83,7 +86,6 @@ BDEPEND="
app-alternatives/yacc
"
-S=${WORKDIR}/${MY_P}/source
PATCHES=(
"${FILESDIR}"/make.patch
"${FILESDIR}"/rltiles-make.patch
diff --git a/games-roguelike/stone-soup/stone-soup-0.27.1-r1.ebuild b/games-roguelike/stone-soup/stone-soup-0.27.1-r1.ebuild
index c22746fce76b..0c67e25b1d5e 100644
--- a/games-roguelike/stone-soup/stone-soup-0.27.1-r1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.27.1-r1.ebuild
@@ -23,18 +23,21 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.27"
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.27"
SRC_URI="
https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
@@ -83,7 +86,6 @@ BDEPEND="
app-alternatives/yacc
"
-S=${WORKDIR}/${MY_P}/source
PATCHES=(
"${FILESDIR}"/make.patch
"${FILESDIR}"/rltiles-make.patch
diff --git a/games-roguelike/stone-soup/stone-soup-0.28.0-r1.ebuild b/games-roguelike/stone-soup/stone-soup-0.28.0-r1.ebuild
index 083a42449f70..a2a5d00a8ad8 100644
--- a/games-roguelike/stone-soup/stone-soup-0.28.0-r1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.28.0-r1.ebuild
@@ -22,39 +22,41 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.28"
# Leave empty string if not a _pre release
COMMITSHA=""
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.28"
if [ -z "${COMMITSHA}" ]; then
# This is a proper release
SRC_URI="
https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
MY_P="stone_soup-${PV}"
else
# This is a _pre release
SRC_URI="
https://github.com/crawl/crawl/archive/${COMMITSHA}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3
diff --git a/games-roguelike/stone-soup/stone-soup-0.29.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.29.1.ebuild
index dd6981ccb593..b3aa85ee3dae 100644
--- a/games-roguelike/stone-soup/stone-soup-0.29.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.29.1.ebuild
@@ -22,7 +22,6 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.29"
# Leave empty string if not a _pre release
COMMITSHA=""
@@ -40,23 +39,26 @@ else
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.29"
SRC_URI="
${SRC_URI}
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3
diff --git a/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
index ef68cd84dd1f..92908ca4accc 100644
--- a/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.30.1.ebuild
@@ -22,7 +22,6 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.30"
# Leave empty string if not a _pre release
COMMITSHA=""
@@ -40,23 +39,26 @@ else
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.30"
SRC_URI="
${SRC_URI}
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3
diff --git a/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild b/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
index 3461e75a1504..aabb2224fe3e 100644
--- a/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.31.0.ebuild
@@ -22,7 +22,6 @@ inherit desktop python-any-r1 lua-single xdg-utils toolchain-funcs
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
HOMEPAGE="https://crawl.develz.org"
-SLOT="0.31"
# Leave empty string if not a _pre release
COMMITSHA=""
@@ -40,23 +39,26 @@ else
"
MY_P="crawl-${COMMITSHA}/crawl-ref"
fi
+# MY_SLOT to satisfy pkgcheck variable order checking
+MY_SLOT="0.31"
SRC_URI="
${SRC_URI}
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${SLOT}.png
- https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${SLOT}.svg
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.png -> ${PN}-${MY_SLOT}.png
+ https://dev.gentoo.org/~stasibear/distfiles/${PN}.svg -> ${PN}-${MY_SLOT}.svg
"
+S=${WORKDIR}/${MY_P}/source
# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
# Public Domain|CC0: most of tiles
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="${MY_SLOT}"
KEYWORDS="amd64 x86"
IUSE="advpng debug ncurses sound test +tiles"
RESTRICT="!test? ( test )"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-S=${WORKDIR}/${MY_P}/source
RDEPEND="
${LUA_DEPS}
dev-db/sqlite:3