summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-07-28 22:19:01 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-07-28 22:35:45 +0100
commit35a178f3a2f996887efc543f76b8eda220b4be3d (patch)
tree1d49a9d5a38091517202233808f9bb40508f3517 /games-server
parentgames-strategy/dunelegacy: Mirror source in devspace (diff)
downloadgentoo-35a178f3a2f996887efc543f76b8eda220b4be3d.tar.gz
gentoo-35a178f3a2f996887efc543f76b8eda220b4be3d.tar.bz2
gentoo-35a178f3a2f996887efc543f76b8eda220b4be3d.zip
games-server/monopd: Bump to 0.10.4, drop old 0.10.2, freshen up
Closes: https://bugs.gentoo.org/919871 Closes: https://bugs.gentoo.org/925847 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-server')
-rw-r--r--games-server/monopd/Manifest2
-rw-r--r--games-server/monopd/files/monopd-0.10.4-fixes.patch82
-rw-r--r--games-server/monopd/files/monopd.in19
-rw-r--r--games-server/monopd/files/monopd.initd11
-rw-r--r--games-server/monopd/monopd-0.10.2-r1.ebuild45
-rw-r--r--games-server/monopd/monopd-0.10.4.ebuild44
6 files changed, 138 insertions, 65 deletions
diff --git a/games-server/monopd/Manifest b/games-server/monopd/Manifest
index 4f77642d6e17..63a7480aa1da 100644
--- a/games-server/monopd/Manifest
+++ b/games-server/monopd/Manifest
@@ -1 +1 @@
-DIST monopd-0.10.2.tar.gz 180317 BLAKE2B a2955149963b63d4839cc65be464c8989f2816bccf8e122833cd5be8be9ded7789e72f59c5f3bb6e2c20d4565cb3553e64dfd2670b003fc5868c40da02948731 SHA512 f47d9623e110a98d9d32b522484944998fb6e7e8644e1f2b439428a1e12b3b514b902e52e7135150135a3e3251aa38604434347d06533f3cf3ffb28a2a81ede3
+DIST monopd-0.10.4.tar.gz 203728 BLAKE2B a32fc2e9fc1e3fb7b615b9fac546056d5c16752ed47e0b2d91868b007042a98ddd7ca1a5f681ee7a8d0e302eb052898f4303b90e3443ae172b6b53a20bbee80d SHA512 60fa9669cf28ff09890a4476a51c1b55c30b160b13f5e083c6302454d3ac38200870269c8982dc627492c4b610ed883a25bf0fc8568513dcc989a83b9805380a
diff --git a/games-server/monopd/files/monopd-0.10.4-fixes.patch b/games-server/monopd/files/monopd-0.10.4-fixes.patch
new file mode 100644
index 000000000000..5157231e6773
--- /dev/null
+++ b/games-server/monopd/files/monopd-0.10.4-fixes.patch
@@ -0,0 +1,82 @@
+From 0a88af9a7a5feba9944ea009eddaac1e89315539 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 28 Jul 2024 22:24:38 +0100
+Subject: [PATCH 1/3] systemd: Correct path to monopd binary
+
+It is installed to /usr/bin, not /usr/sbin.
+---
+ doc/systemd/monopd.service | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/systemd/monopd.service b/doc/systemd/monopd.service
+index eace183..3f370d4 100644
+--- a/doc/systemd/monopd.service
++++ b/doc/systemd/monopd.service
+@@ -3,7 +3,7 @@ Description=game server for board games like GtkAtlantic
+
+ [Service]
+ Type=notify
+-ExecStart=/usr/sbin/monopd
++ExecStart=/usr/bin/monopd
+ User=nobody
+ Group=nogroup
+
+--
+2.45.2
+
+
+From fb41002ae3b94c6d9b3587ed291810baf04af19f Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 28 Jul 2024 22:26:21 +0100
+Subject: [PATCH 2/3] autoconf: Don't mix up CFLAGS with CXXFLAGS
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index fa0de41..e388422 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,7 @@ AC_LANG(C++)
+ AC_SEARCH_LIBS([strerror], [cposix])
+ AC_SUBST(CFLAGS, $CFLAGS)
+ AC_PROG_CC
+-AC_SUBST(CXXFLAGS, $CFLAGS)
++AC_SUBST(CXXFLAGS, $CXXFLAGS)
+ AC_PROG_CXX
+
+ # Checks for libraries.
+--
+2.45.2
+
+
+From 770eb6f7a82012776071d7af4e2c5b54d27ffb50 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 28 Jul 2024 22:27:13 +0100
+Subject: [PATCH 3/3] autoconf: Fix appending of C(XX)FLAGS
+
+configure uses /bin/sh, which may be a pure POSIX shell like dash rather
+than bash. += is not POSIX compliant.
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e388422..24cc00c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -41,8 +41,8 @@ AS_IF([test "x$USE_SYSTEMD_DAEMON" != "xno"], [
+ ])
+
+ if test "x$GCC" = "xyes"; then \
+- CFLAGS+=" -Wall -Wextra"; \
+- CXXFLAGS+=" -Wall -Wextra"; \
++ CFLAGS="${CFLAGS} -Wall -Wextra"; \
++ CXXFLAGS="${CXXFLAGS} -Wall -Wextra"; \
+ fi
+
+ AC_CONFIG_FILES([
+--
+2.45.2
+
diff --git a/games-server/monopd/files/monopd.in b/games-server/monopd/files/monopd.in
deleted file mode 100644
index 9a0fbda55ffb..000000000000
--- a/games-server/monopd/files/monopd.in
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting monopd server"
- start-stop-daemon --start -q -b --exec GENTOO_DIR/monopd
- eend $?
-}
-
-stop() {
- ebegin "Stopping monopd server"
- start-stop-daemon --stop -q --exec GENTOO_DIR/monopd
- eend $?
-}
diff --git a/games-server/monopd/files/monopd.initd b/games-server/monopd/files/monopd.initd
new file mode 100644
index 000000000000..80b93090d3da
--- /dev/null
+++ b/games-server/monopd/files/monopd.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="monopd"
+command_background="true"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ use net
+}
diff --git a/games-server/monopd/monopd-0.10.2-r1.ebuild b/games-server/monopd/monopd-0.10.2-r1.ebuild
deleted file mode 100644
index da2bf28824fe..000000000000
--- a/games-server/monopd/monopd-0.10.2-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic systemd
-
-DESCRIPTION="server for atlantik games"
-HOMEPAGE="http://gtkatlantic.gradator.net/"
-SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="systemd"
-
-RDEPEND="systemd? ( sys-apps/systemd )"
-DEPEND="${RDEPEND}
- >=dev-cpp/muParser-2
- dev-libs/utfcpp"
-
-src_prepare() {
- default
-
- sed "s:GENTOO_DIR:\"/usr/bin\":" \
- "${FILESDIR}"/monopd.in > "${T}"/monopd || die
- sed -i \
- -e "s:/usr/sbin:/usr/bin:" \
- doc/systemd/monopd.service || die
- sed -i \
- -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
- configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- append-cppflags -I"/usr/include/utf8cpp"
- econf $(use_with systemd systemd-daemon)
-}
-
-src_install() {
- default
- doinitd "${T}"/monopd
- systemd_dounit doc/systemd/monopd.s*
-}
diff --git a/games-server/monopd/monopd-0.10.4.ebuild b/games-server/monopd/monopd-0.10.4.ebuild
new file mode 100644
index 000000000000..386dab481c7d
--- /dev/null
+++ b/games-server/monopd/monopd-0.10.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Server for the GtkAtlantic board game"
+HOMEPAGE="https://gtkatlantic.gradator.net"
+SRC_URI="https://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-cpp/muParser-2
+ dev-libs/utfcpp
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fixes.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -I"${ESYSROOT}/usr/include/utf8cpp"
+ econf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use systemd && systemd_dounit doc/systemd/${PN}.s*
+}