summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-22 01:56:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-22 01:57:09 +0100
commitd676574b43da7591fd7bd181b8347692e28262d9 (patch)
treeed7257df8646b28e89ae10a59af24b5d790fb222 /games-util
parentsys-apps/dbus: Add bug reference (diff)
downloadgentoo-d676574b43da7591fd7bd181b8347692e28262d9.tar.gz
gentoo-d676574b43da7591fd7bd181b8347692e28262d9.tar.bz2
gentoo-d676574b43da7591fd7bd181b8347692e28262d9.zip
games-util/joystick: Bump to version 1.6.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joystick/Manifest1
-rw-r--r--games-util/joystick/joystick-1.6.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index 3f78eb0abea2..210ac3641d26 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1 +1,2 @@
DIST linuxconsoletools-1.6.0.tar.bz2 50563 BLAKE2B 26f68f4a9a4af5b875bc7efcc70edd80978a560f62c415b4957ee851260a2f6e6227c5a3001fb009777eac7e19d0449a8335486290ae0aaa9467ad8e1e9a89fb SHA512 35ca923cceca729bcbab95dff18682abd0d87a297e70aa8707fbabccde018fef0775a99195af4bf9111ba33210a14c10d1a766f83112cd535930a1ae430c7c75
+DIST linuxconsoletools-1.6.1.tar.bz2 50854 BLAKE2B 0614e72226c575499ae5976011a0fca146a1981e2d355f7554f105b184bdd4f1090bf5374377e89f3881c5476e3c3a362b70f86cfd83440264066ea50a8c6a4b SHA512 b520c0a2d55986204619e3a5a00fb8b1e26453ac6df4f51c8c87495661a68bb6fe5a1947a3e079a53a537bf06d23c73c404a4d7e4d4dd18c0f7f69c1985a77be
diff --git a/games-util/joystick/joystick-1.6.1.ebuild b/games-util/joystick/joystick-1.6.1.ebuild
new file mode 100644
index 000000000000..389255caf332
--- /dev/null
+++ b/games-util/joystick/joystick-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if ! use udev ; then
+ rm "${ED}"/usr/bin/jscal-{re,}store || die
+ fi
+}