summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-06 10:21:57 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-06 10:42:14 -0400
commitde33f602e99a1b42198953ca75cd6ab507d85d14 (patch)
treead834c3971d0cd0a78edab79b156ff489f6456aa /gnome-extra/tecla
parentapp-text/nuspell: Drop EAPI 7 ebuild (diff)
downloadgentoo-de33f602e99a1b42198953ca75cd6ab507d85d14.tar.gz
gentoo-de33f602e99a1b42198953ca75cd6ab507d85d14.tar.bz2
gentoo-de33f602e99a1b42198953ca75cd6ab507d85d14.zip
gnome-extra/tecla: Version bump to 45_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32651 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/tecla')
-rw-r--r--gnome-extra/tecla/Manifest1
-rw-r--r--gnome-extra/tecla/tecla-45_rc.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gnome-extra/tecla/Manifest b/gnome-extra/tecla/Manifest
index 422342737f5d..51c03314d7ed 100644
--- a/gnome-extra/tecla/Manifest
+++ b/gnome-extra/tecla/Manifest
@@ -1 +1,2 @@
DIST tecla-45.beta.tar.xz 33464 BLAKE2B 1f33da97c39be682f5f03e991f3d83e41194b17761bbbb6a27ce026de4eb481c6b2f577a0b7b6c3858fef1544498b98bc50c6a4ea02e266c4edc15555571c738 SHA512 93acf3fe93001be51638743dc85686d07abc9e0a138efbcbd39a0d2ae360b9e1dafbbd7c4b101e3b0141d18710b5557cf60438e2220cc7420699d8151542e989
+DIST tecla-45.rc.tar.xz 32432 BLAKE2B 579ac19298e48b3d37385068ce2fb8a4cace368cc1908c7287377a2e45655658d3124c3e0913bc0223af7436a2e20caad723603f9775a5141d5a6826f900d087 SHA512 7f0bf8559b5f99a52516f1a2c340574b1e76c65f6d72264f8099e34e38c39f2019b81c692517cab309f657eb7806adb4bac5338ad2212a0bbaca4e280182e65d
diff --git a/gnome-extra/tecla/tecla-45_rc.ebuild b/gnome-extra/tecla/tecla-45_rc.ebuild
new file mode 100644
index 000000000000..5cfd87a92364
--- /dev/null
+++ b/gnome-extra/tecla/tecla-45_rc.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tecla is a keyboard layout viewer"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/tecla"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-libs/gtk:4[introspection]
+ >=gui-libs/libadwaita-1.4_alpha:1
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/glib
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}