summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-11-08 21:17:39 +0100
committerPacho Ramos <pacho@gentoo.org>2024-11-08 21:18:39 +0100
commit30036425b4ebd5b21a22b5e85e15d3859f73bdd1 (patch)
treef807880782301459372608acb19e2421c6a665e1 /gnome-extra
parentapp-misc/geoclue: add 2.7.2 (diff)
downloadgentoo-30036425b4ebd5b21a22b5e85e15d3859f73bdd1.tar.gz
gentoo-30036425b4ebd5b21a22b5e85e15d3859f73bdd1.tar.bz2
gentoo-30036425b4ebd5b21a22b5e85e15d3859f73bdd1.zip
gnome-extra/libgsf: add 1.14.53
Bug: https://bugs.gentoo.org/940777 Bug: https://bugs.gentoo.org/923132 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.53.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index 35f23a38a722..7118cad67eed 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.52.tar.xz 707580 BLAKE2B 01f03f8c289388ab63ff67786fa2eac745e4233475d01544d7149a52d1f6043145acbab2e3c28dbaadfa20e5197c6d7f2316385879cd148dd55fb37e16999888 SHA512 3a7af5eae2aa539181dd0ae0d0ce4110da4c430ed8a26cdd7f0ec84c9bcf86360cceabf81ec7c6b902f2fe8d7ea5e3c09fa911d6bab3162f0f531e6973137f4b
+DIST libgsf-1.14.53.tar.xz 714840 BLAKE2B 2a8f2c51efda730648a33df6492d4877494520cfe96445468a0921304f620c12546747ac1f0a36575edbfd5d260709d10ea43119ecff8cf6171403a348514b0b SHA512 f2f8fa0806bf2edae271b3503cc311bd7ba32c145530afce382305cacfaae624edbc8298bd8766364e94804e71b1b8d0aac8383ae514aad646f2a926727cf727
diff --git a/gnome-extra/libgsf/libgsf-1.14.53.ebuild b/gnome-extra/libgsf/libgsf-1.14.53.ebuild
new file mode 100644
index 000000000000..081a1e0e3686
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.53.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GNOME2_EAUTORECONF=yes
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-build/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.14.49-skip-valgrind-tests.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}