summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-08-27 10:11:32 +0200
committerPacho Ramos <pacho@gentoo.org>2024-08-27 10:24:49 +0200
commit5d852dbd94098516102e7db549aac51af7918ffc (patch)
tree67e771ec9feeb113d4938f4c18d34856bde0c830 /gnome-extra
parentapp-text/wv: Add gsf-doc-meta-data.patch (diff)
downloadgentoo-5d852dbd94098516102e7db549aac51af7918ffc.tar.gz
gentoo-5d852dbd94098516102e7db549aac51af7918ffc.tar.bz2
gentoo-5d852dbd94098516102e7db549aac51af7918ffc.zip
gnome-extra/gnome-shell-extension-appindicator: add 59
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-59.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index b8b5477984bd..83425d7937a9 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-appindicator-57.tar.gz 67246 BLAKE2B cdbfce7c2ff731732dea76ce53421424ad887ab7c95b555142f1fccb549723c9f9816cde527dd0dca6b9c6b835d9ec8d255f8350f8d772199920ac69d2d26809 SHA512 256d365a653db40490cb0d4da5ee5f7508298bc9189e0a8e98a4f1c904f5627cd0cb1b5586786005638025e3b8a31bf948d08a69a40977887b5860f8dc5ee53e
DIST gnome-shell-extension-appindicator-58.tar.gz 68877 BLAKE2B 976310cb6d532adf522c2d51bf04d6c5ee78e76759dbc8ab8965b1c738e5077be26b62e3c25f30b6a6311f98427d88c498ed839c0e401d86f9d701343229ae67 SHA512 94919a1494e354d8ef081fc3b844c092369f0b0928fa94f5677cecede87bff1e8669b6b064e4ed9d40ddb9f536f68075776e5afafb06cc3df33e3b83387ea6f8
+DIST gnome-shell-extension-appindicator-59.tar.gz 69210 BLAKE2B 02d88f1d965edcf5eb04b72a1d51cef6a34485ed78240ea0e15de56b8d8d712a0721f2ba7cc51627a60407573bf7fd073da9f288e50ab6f791e64e72245e4986 SHA512 e85bea82b85369248b8271f32a276f7939bdd0828f4f63cfe0faf7099249cbbd56e2f58460373431602390f88ea97c1375655b454b0ec4c0e52280b6502bbc98
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-59.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-59.ebuild
new file mode 100644
index 000000000000..7090304530b4
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-59.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_prepare() {
+ default
+ # https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/419
+ eapply -R "${FILESDIR}/${PN}-53-41a8e9c.patch"
+}
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}