summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas PARLANT <nicolas.parlant@parhuet.fr>2024-12-25 21:07:32 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-28 01:04:44 +0100
commitc9ed3d7aadd92ea9898c0433cfdfd76abd4c937a (patch)
treebd697550e4e8bab88f3e62fadbcbeae1373107ac /gnome-extra
parentapp-emacs/emms: Fix DEPEND, cleanup superfluous empty lines (diff)
downloadgentoo-c9ed3d7aadd92ea9898c0433cfdfd76abd4c937a.tar.gz
gentoo-c9ed3d7aadd92ea9898c0433cfdfd76abd4c937a.tar.bz2
gentoo-c9ed3d7aadd92ea9898c0433cfdfd76abd4c937a.zip
gnome-extra/gnome-commander: Add media-libs/taglib:= slot op
ABI break imminent Committer-comment: de-stabilising not necessary Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.18.1-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.18.1-r1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..98db294fc680
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.18.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson optfeature virtualx
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="https://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc exif gsf pdf samba taglib test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ doc? ( gnome-extra/yelp )
+ >=dev-libs/glib-2.70.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ exif? ( >=media-gfx/exiv2-0.14:= )
+ gsf? ( >=gnome-extra/libgsf-1.12:= )
+ pdf? ( >=app-text/poppler-0.18:=[cairo] )
+ samba? ( gnome-base/gvfs[samba] )
+ taglib? ( media-libs/taglib:= )
+"
+BDEPEND="
+ doc? ( app-text/yelp-tools )
+ dev-util/glib-utils
+ dev-build/gtk-doc-am
+ app-alternatives/lex
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.7.0 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature exif exiv2)
+ $(meson_feature gsf libgsf)
+ $(meson_feature pdf poppler)
+ $(meson_feature samba)
+ $(meson_feature taglib)
+ $(meson_feature test tests)
+ $(meson_use doc help)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ optfeature "synchronizing files and directories" dev-util/meld
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}