summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-05 16:59:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-05 19:19:37 -0600
commitc7979daf0d7c95bbe536c724f1386602f499d51c (patch)
tree969e363790674b2da9e0f86f9251757ee5681e6d /gui-apps/swayidle
parentgui-apps/swayidle: update minimum wayland-protocols version (diff)
downloadgentoo-c7979daf0d7c95bbe536c724f1386602f499d51c.tar.gz
gentoo-c7979daf0d7c95bbe536c724f1386602f499d51c.tar.bz2
gentoo-c7979daf0d7c95bbe536c724f1386602f499d51c.zip
gui-apps/swayidle: add 1.8.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps/swayidle')
-rw-r--r--gui-apps/swayidle/Manifest1
-rw-r--r--gui-apps/swayidle/swayidle-1.8.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gui-apps/swayidle/Manifest b/gui-apps/swayidle/Manifest
index 6f7add92781a..e54015bf4700 100644
--- a/gui-apps/swayidle/Manifest
+++ b/gui-apps/swayidle/Manifest
@@ -1,2 +1,3 @@
DIST swayidle-1.7.1.tar.gz 13285 BLAKE2B 698f9d75977746631290b92787b33015483ffec4ed1b84386b393bfd20dd65a6dc309de6ef1a01b00b9b96563fcd423d5994d19f03094d1c1ac6382abde898a2 SHA512 6e0a6eb3b99a415414cac04299392ede9a8263fa5f4a75815742f5fcd4a5badb3021a7ff699a476c04ca2256b85f4149f8c8dda0484306636ffbaccff615d9da
DIST swayidle-1.7.tar.gz 12458 BLAKE2B 06462d286e4786173d26241056c2b0c71a9253eac31e0b33bd70c5729ff172c3b8ab2c6377c3bc4a6f53cf580adbaac792d90f46da7f944bcc5a4055b642fe5a SHA512 26a48c510caaadb1ad694426e82880ab1547b7b0ef8ac62a2c2ee41c7b8cc0554f4925b0abdc6dc37f2501a171c0b6ae53c56b045b5c545093f3b0463aefcf24
+DIST swayidle-1.8.0.tar.gz 13610 BLAKE2B 0eeb83b1ff77dc0a4288280e680da988471651c9ca635641f8fadfc89c3db24f814535c5e2b8854c39d7ff2d2f76181cb758251a550e7e1f532d077468f8962c SHA512 92b482e24926e645c33e29e7ed88912294a375ec625c0c8d85bc6aeeb6691f9cbfc05e88533465702667e479daeaae915481907526f7c862cb81622745f1ce68
diff --git a/gui-apps/swayidle/swayidle-1.8.0.ebuild b/gui-apps/swayidle/swayidle-1.8.0.ebuild
new file mode 100644
index 000000000000..401c403c41b6
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-1.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +man systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.27
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
+ "-Dbash-completions=true"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}