summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-02-06 01:44:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-07 12:01:25 +0200
commit52df57a4f1e92549962c503693ce9a8b40588603 (patch)
treedeb78a2c1e57967ad5057ce3f29d100d35e709aa /gui-apps/wf-recorder/wf-recorder-9999.ebuild
parentdev-python/spyder: add 5.5.1 (diff)
downloadgentoo-52df57a4f1e92549962c503693ce9a8b40588603.tar.gz
gentoo-52df57a4f1e92549962c503693ce9a8b40588603.tar.bz2
gentoo-52df57a4f1e92549962c503693ce9a8b40588603.zip
gui-apps/wf-recorder: add 0.4.1
Corresponding release: - https://github.com/ammen99/wf-recorder/releases/tag/v0.4.1 These changes also add the pulseaudio USE flag. Closes: https://bugs.gentoo.org/871684 Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Co-authored-by: Arthur Zamarin <arthurzam@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/35161 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps/wf-recorder/wf-recorder-9999.ebuild')
-rw-r--r--gui-apps/wf-recorder/wf-recorder-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/gui-apps/wf-recorder/wf-recorder-9999.ebuild b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
index fd58d11409c9..3a7ded597607 100644
--- a/gui-apps/wf-recorder/wf-recorder-9999.ebuild
+++ b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,11 +18,13 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="pulseaudio"
DEPEND="
dev-libs/wayland
- media-libs/libpulse
- media-video/ffmpeg[pulseaudio,x264]
+ media-libs/mesa[wayland]
+ media-video/ffmpeg[pulseaudio?,x264]
+ pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}"
BDEPEND="
@@ -30,3 +32,10 @@ BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pulseaudio pulse)
+ )
+ meson_src_configure
+}