summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-26 01:56:25 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:55:18 +0200
commite22100de6bd58974d68871de90860b78ec23931f (patch)
tree42a118f34e3f7762ebe4c5aca42f9226345e55cf /gui-apps/wf-shell
parentgui-libs/wayfire-plugins-extra: add 0.8.0 (diff)
downloadgentoo-e22100de6bd58974d68871de90860b78ec23931f.tar.gz
gentoo-e22100de6bd58974d68871de90860b78ec23931f.tar.bz2
gentoo-e22100de6bd58974d68871de90860b78ec23931f.zip
gui-apps/wf-shell: add 0.8.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/33990 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps/wf-shell')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.8.0.ebuild52
-rw-r--r--gui-apps/wf-shell/wf-shell-9999.ebuild15
3 files changed, 64 insertions, 4 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index 50a3e27f9293..b85a8c694114 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1 +1,2 @@
DIST wf-shell-0.7.0.tar.xz 9014840 BLAKE2B f2e1ffb76de79db580227ddefc10c9f3431c92f77e6519da1102e7c4456bb30c4f25c82570a5b2796985dac00be65f9428ac6682e80920ed22359f63e3e6a84d SHA512 3d72c5d399280ee9da841a417faf696f8baa40edc1040bc1f354f113a8e431dbab428c93928b1d3faa520e35211345cabb5c70f55e10cfb7a4c321a6db19df90
+DIST wf-shell-0.8.0.tar.xz 9100508 BLAKE2B 0867f9968fca25d183fb912e01afc55ae6c9e3a0645eb63b2622ed53bb5d6538827a8e1bb6c68be4885f0c1513e76f0fd8f580402885bfa49dcbc7a0b8b02b49 SHA512 cdaebb4aabcfcb4a4d2ef0f7845348892e5731cc44417861b958d3f067f19b6bab002845d7663ef50f57e462664ff1ca0cdab74257109211db8fa20a47ef53ae
diff --git a/gui-apps/wf-shell/wf-shell-0.8.0.ebuild b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
new file mode 100644
index 000000000000..1cfcb8cbb345
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="+pulseaudio"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0[wayland]
+ dev-libs/gobject-introspection
+ dev-libs/libdbusmenu
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wf-shell/wf-shell-9999.ebuild b/gui-apps/wf-shell/wf-shell-9999.ebuild
index 0734bbb0cb13..1cfcb8cbb345 100644
--- a/gui-apps/wf-shell/wf-shell-9999.ebuild
+++ b/gui-apps/wf-shell/wf-shell-9999.ebuild
@@ -11,20 +11,27 @@ HOMEPAGE="https://github.com/WayfireWM/wf-shell"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
IUSE="+pulseaudio"
+# no tests
+RESTRICT="test"
+
DEPEND="
- dev-cpp/gtkmm:3.0=[wayland]
+ dev-cpp/gtkmm:3.0[wayland]
dev-libs/gobject-introspection
- gui-libs/gtk-layer-shell
- >=gui-wm/wayfire-${PV%.*}
+ dev-libs/libdbusmenu
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}